Bug 469158 - base directory option (--base-dir) not recognized
base directory option (--base-dir) not recognized
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: shadow-utils (Show other bugs)
5.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: Peter Vrabec
BaseOS QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-30 07:06 EDT by Eduard Benes
Modified: 2010-03-30 04:13 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-30 04:13:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eduard Benes 2008-10-30 07:06:16 EDT
Current RHEL-5.3 version of adduser does not recognize base directory option (--base-dir). 

Current behaviour:
<snip>
# mkdir /home/servers
# adduser -b /home/servers/ baad
Usage: useradd [options] LOGIN

Options:
  -b, --base-dir BASE_DIR       base directory for the new user account
                                home directory
 ...
# echo $?
2
# userdel baad
userdel: user baad does not exist
# rpm -qf `which adduser`
shadow-utils-4.0.17-14.el5.i386
</snip>

Desired behaviour:
Successfully create home directory and add new user ...
Comment 1 Eduard Benes 2008-10-31 13:38:23 EDT
This works in F9, but does not work in RHEL-5 since GOLD. Also, does not work in RHEL-4.7.

Behaviour in F9:
# mkdir -p /home/server/misc/
# adduser -b /home/server/misc/ test
# ls -dla /home/server/misc/test/
drwx------ 4 test test 4096 2008-10-31 18:33 /home/server/misc/test/
# rpm -q shadow-utils
shadow-utils-4.1.1-4.fc9.i386
Comment 2 RHEL Product and Program Management 2009-03-26 13:13:44 EDT
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 8 errata-xmlrpc 2010-03-30 04:13:27 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2010-0209.html

Note You need to log in before you can comment on or make changes to this bug.