Bug 469161 - schema upgrade 0.2 -> 0.3 fails
schema upgrade 0.2 -> 0.3 fails
Status: CLOSED CURRENTRELEASE
Product: Spacewalk
Classification: Community
Component: Installation (Show other bugs)
0.3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jan Pazdziora
Milan Zázrivec
:
Depends On:
Blocks: space03
  Show dependency treegraph
 
Reported: 2008-10-30 07:23 EDT by Milan Zázrivec
Modified: 2009-09-17 03:02 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-17 03:02:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milan Zázrivec 2008-10-30 07:23:25 EDT
Description of problem:
After successful yum upgrade spacewalk:

# spacewalk-schema-upgrade 
Schema upgrade: [spacewalk-schema-0.2.5-1.el5.sw] -> [spacewalk-schema-0.3.4-1.el5.sw]
Searching for upgrade path: [spacewalk-schema-0.2.5-1] -> [spacewalk-schema-0.3.4-1]
Searching for upgrade path: [spacewalk-schema-0.2.5] -> [spacewalk-schema-0.3.4]
Searching for upgrade path: [spacewalk-schema-0.2] -> [spacewalk-schema-0.3]
Was not able to find upgrade path in directory [/etc/sysconfig/rhn/schema-upgrade].

# ls -l /etc/sysconfig/rhn/schema-upgrade/
total 16
lrwxrwxrwx 1 root root    27 Oct 30 11:57 rhn-satellite-schema-5.1-to-spacewalk-schema-0.2 -> satellite-5.1-spacewalk-0.2
drwxr-xr-x 2 root root 12288 Oct 30 11:57 satellite-5.1-spacewalk-0.2
drwxr-xr-x 2 root root  4096 Oct 30 11:57 spacewalk-0.2-spacewalk-0.3

Supposedly spacewalk-schema-upgrade is unable to find upgrade path
because of missing link in /etc/sysconfig/rhn/schema-upgrade
spacewalk-schema-0.2.5-1-to-spacewalk-schema-0.3.4-1 pointing to
spacewalk-0.2-spacewalk-0.3

Version-Release number of selected component (if applicable):
spacewalk-schema-0.3.4-1.el5.sw
Comment 1 Jan Pazdziora 2008-10-30 09:14:24 EDT
Added the missing symlink, commits 04111dcbd0ef4a329a32589180cb85d6b2762506 and
1eb90beaa5a61b34f4ddf5b86ac071b59852f965.
Comment 2 Jan Pazdziora 2008-10-30 09:30:52 EDT
Packages spacewalk-schema-0.3.5-1.el[45].sw tagged and built.
Comment 3 Milan Zázrivec 2008-11-04 09:38:15 EST
Problem was fixed in spacewalk-schema-0.3.5-1 -> Verified.
Comment 4 Miroslav Suchý 2009-09-17 03:02:25 EDT
Spacewalk has been released for some time.

Note You need to log in before you can comment on or make changes to this bug.