Bug 469164 - Fluendo MP3 codec blocked by SELinux
Fluendo MP3 codec blocked by SELinux
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: codeina (Show other bugs)
rawhide
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-30 07:46 EDT by Łukasz Lis
Modified: 2008-10-30 10:46 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-30 10:46:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Łukasz Lis 2008-10-30 07:46:26 EDT
Description of problem:
SELinux prevents Fluendo's mp3 codec from working. An alert will show up every time an application tries to use it.

Version-Release number of selected component (if applicable):
codeina-0.10.1-9.fc10 

How reproducible: always

Steps to Reproduce:
1. Start rhythmbox
2. Play an mp3 file
or
1. Start totem
2. Play an mp3 file or video with mp3 audio
or
1. Play an mp3 from console with gst-launch:
$ gst-launch filesrc location=music.mp3 ! flump3dec ! pulsesink
  
Actual results:
Silence.
A SELinux alert pops up and, in the case of gst-launch, a console message will show up:

(gst-launch-0.10:3841): GStreamer-WARNING **: Failed to load plugin '/home/user/.gstreamer-0.10/plugins/libgstflump3dec.so': /home/user/.gstreamer-0.10/plugins/libgstflump3dec.so: cannot enable executable stack as shared object requires: Permission denied

The SELinux alert states:
SELinux is preventing gst-launch-0.10 from making the program stack executable. 

Expected results:
No alerts and proper playback.

Additional info:
Totem and Rhythmbox will fall back to ffmpeg if gstreamer-ffmpeg installed.
I'm not sure but this bug looks like regression:
https://bugzilla.redhat.com/show_bug.cgi?id=298741
Comment 1 Bastien Nocera 2008-10-30 10:46:12 EDT
See upstream: https://core.fluendo.com/gstreamer/trac/ticket/24

Note You need to log in before you can comment on or make changes to this bug.