Bug 469192 - Failures when updating firstboot
Failures when updating firstboot
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: firstboot (Show other bugs)
5.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: Chris Lumens
Alexander Todorov
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-30 10:51 EDT by Alexander Todorov
Modified: 2009-01-20 17:06 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 17:06:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Todorov 2008-10-30 10:51:10 EDT
Description of problem:
Upgrading firstboot-1.4.27.6-1.el5.x86_64
/var/tmp/rpm-tmp.78685: line 25: [: 27905VERSION: integer expression expected
/var/tmp/rpm-tmp.78685: line 25: [: 27905VERSION: integer expression expected
/var/tmp/rpm-tmp.78685: line 25: [: 27905VERSION: integer expression expected


Version-Release number of selected component (if applicable):
firstboot-1.4.27.6-1.el5

How reproducible:
Consistent

Steps to Reproduce:
1. Install 5.2 server @everything
2. upgrade to 5.3 with anaconda or yum

  
Actual results:
Above error

Expected results:
No errors

Additional info:
I've discussed this earlier with Panu wrt glibc changes but IIRC we couldn't figure out what was going on. The issue is that messages count increased from 1 to 3-4 messages. 

It's possible that the messages are emitted out of band and not related to firstboot. Also the integer in front of "VERSION" is different every time.
Comment 1 Chris Lumens 2008-10-30 10:53:59 EDT
Perhaps this is something else related to scriptlet processing?  These are the scriptlets in the (rather old) firstboot spec file:

%preun
if [ $1 = 0 ]; then
  rm -rf /usr/share/firstboot/*.pyc
  rm -rf /usr/share/firstboot/modules/*.pyc
fi

%preun tui
if [ $1 = 0 ]; then
  chkconfig --del firstboot
fi
Comment 2 Alexander Todorov 2008-10-30 11:57:32 EDT
Looking at the %preun I see the same issue as with system-config-kickstart package. We're removing the *.pyc files.
Comment 3 Chris Lumens 2008-10-30 14:01:55 EDT
Well, firstboot is an approved component so let's take care of this while we've got a chance.
Comment 5 Chris Lumens 2008-10-31 14:20:48 EDT
This should be fixed in firstboot-1.4.27.6-2.
Comment 9 errata-xmlrpc 2009-01-20 17:06:38 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0229.html

Note You need to log in before you can comment on or make changes to this bug.