Bug 469202 - View Certificates does not show your certificates by default; you have to click the single tab that shows up in order to see them
View Certificates does not show your certificates by default; you have to cli...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: esc (Show other bugs)
5.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: Jack Magne
desktop-bugs@redhat.com
: Desktop, Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-30 11:36 EDT by Suzanne Hillman
Modified: 2009-01-20 15:51 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 15:51:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Suzanne Hillman 2008-10-30 11:36:49 EDT
Description of problem:
View Certificates does not show your certificates by default; you have to click the single tab that shows up in order to see them. This is very counter-intuitive. Not sure if this is required to fix, but I'm sure this is a regression.

Version-Release number of selected component (if applicable):
esc-1.0.0-37.el5

How reproducible:
Always

Steps to Reproduce:
1. Insert a formatted, enrolled smartcard, causing ESC to start up for the first time on a newly installed system
2. Click 'View Certificates'
  
Actual results:
See the certs on the machine.

Expected results:
See the certs on the card you have inserted and highlighted!

Additional info:
Comment 1 Jack Magne 2008-10-30 12:57:44 EDT
I can take a quick look at it to see if it is an easy fix when I get a moment.  Thanks for the catch.
Comment 2 RHEL Product and Program Management 2008-11-07 16:20:30 EST
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being proposed as a blocker for this release.  

Please resolve ASAP.
Comment 3 Jack Magne 2008-11-07 17:47:35 EST
I checked this out on my box and I can't seem to duplicate it. Perhaps this is another sporadic issue. Will keep working it.
Comment 4 Jack Magne 2008-11-07 18:14:04 EST
Actually, regardless of whether it happens to me or not, I have located an easy fix for this.  There is a minor alteration to the XUL file that will make sure our tab is selected. Before It seems to work ok most of the time by accident.
Comment 5 Suzanne Hillman 2008-11-10 10:37:21 EST
Additional information: Only happens the first time you try it after an install. After that point it does not (may or may not happen if you try as a different user, not sure).
Comment 6 Jack Magne 2008-11-10 12:57:12 EST
Regardless, I fully believe I have a fix which should work. Thanks!
Comment 8 Bob Relyea 2008-12-04 14:28:39 EST
devel_ack
Comment 11 Jack Magne 2008-12-08 12:42:04 EST
Issue resolved in build esc-1.0.0-39.
Comment 15 errata-xmlrpc 2009-01-20 15:51:23 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0085.html

Note You need to log in before you can comment on or make changes to this bug.