Bug 469211 - failed to execute /init in diskless client
failed to execute /init in diskless client
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: system-config-netboot (Show other bugs)
5.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: Jaroslav Reznik
BaseOS QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-30 12:16 EDT by Gerben Roest
Modified: 2014-09-15 09:29 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-02 09:07:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gerben Roest 2008-10-30 12:16:21 EDT
Description of problem: booted diskless client says "failed to execute /init"


Version-Release number of selected component (if applicable):
system-config-netboot-0.1.45.1-1.el5


How reproducible: always


Steps to Reproduce:
1. run system-config-netboot
2. pxe boot a client
3.
  
Actual results: "failed to execute /init"


Expected results: it should run /init


Additional info:

The package system-config-netboot version 0.1.45.1-1 makes a pxelinux boot "append" that says (among others): init=disklessrc. In the initrd.img it creates, there is no disklessrc, but only an "init" file which is in fact the disklessrc. So I changed "init=disklessrc" to "init=init" but it still fails to execute /init. If I remove the "init=disklessrc" alltogether, it still fails. 

So actually there are two bugs: It should not say "init=disklessrc" AND it should not fail to execute /init.
Comment 1 Rodney Wilsoncroft 2009-11-06 12:19:50 EST
I'm having the same exact problem, is a solution available for this?
Comment 2 tom wolstencroft 2010-09-17 17:10:33 EDT
Any update on this?  I am having the same problem with RHEL 5.5.  There were several errors in the disklessrc script where /sbin/grep /sbin/hostname and /sbin/sed were called instead of using /bin.  Also /bin/dhclient was called instead of /sbin/.

Even after fixing these, I get the "failed to execute /init" error.  


Any help would be greatly appreciated.
Comment 3 RHEL Product and Program Management 2014-03-07 08:39:22 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 4 RHEL Product and Program Management 2014-06-02 09:07:51 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).

Note You need to log in before you can comment on or make changes to this bug.