Bug 469214 - no kms for ATI Technologies Inc Unknown (0x71d2)
no kms for ATI Technologies Inc Unknown (0x71d2)
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-30 12:25 EDT by Jack Tanner
Modified: 2009-12-18 01:42 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-18 01:42:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log generated using an xorg.conf (155.97 KB, text/plain)
2008-12-02 17:04 EST, Jack Tanner
no flags Details
xorg.conf (4.30 KB, text/plain)
2008-12-02 17:05 EST, Jack Tanner
no flags Details
Xorg.0.log generated using an xorg.conf (158.18 KB, text/plain)
2008-12-19 12:06 EST, Jack Tanner
no flags Details

  None (edit)
Description Jack Tanner 2008-10-30 12:25:52 EDT
Description of problem:

F10 beta 3 snapshot gives no kernel modesetting love to 

(--) PCI:*(0@2:0:0) ATI Technologies Inc unknown chipset (0x71d2) rev 0, Mem @ 0xe8000000/134217728, 0xfdbf0000/65536, I/O @ 0x00009c00/256, BIOS @ 0x????????/131072
(--) PCI: (0@2:0:1) ATI Technologies Inc unknown chipset (0x71f2) rev 0, Mem @ 0xfdbe0000/65536

See hardware profile

http://www.smolts.org/client/show/pub_868ba156-1c6d-47e0-9f9e-22aec3671cc5
Comment 1 Matěj Cepl 2008-10-30 18:33:27 EDT
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and let X11 autodetect your display and video card? Attach to this bug /var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Bruno Wolff III 2008-11-08 16:25:26 EST
That's odd. I have a FireGL 3400 that uses the ids 71d2 and 71f2 and kernel modesetting is working reasonably well. There have been problems at times and I don't remember how things worked around the time of snapshot3. If you upgrade to at least the preview release, things should be usable. You can also get more recent updates from koji.
Comment 3 Matěj Cepl 2008-11-10 12:48:56 EST
Reporter, if you pick the last build from http://koji.fedoraproject.org/koji/packageinfo?packageID=95, does it help?
Comment 4 Jack Tanner 2008-11-10 13:22:47 EST
Dammit, it's tough to test fixes that affect boot when you're running from a live CD distro. :)

I'll try to set aside a partition to test this.
Comment 5 Matěj Cepl 2008-11-10 16:14:49 EST
(In reply to comment #4)
> Dammit, it's tough to test fixes that affect boot when you're running from a
> live CD distro. :)

Sorry, I missed that again. But there is certainly newer LiveCD than Beta3 -- take a look at http://torrent.fedoraproject.org/ Does using that CD help?

> I'll try to set aside a partition to test this.

Yeah, that would be lovely. But don't sweat over it too much -- we have plenty of bugs and bug reporters telling us how bad our X drivers are :) So if this bug will end in vain, we will certainly some others to help us to improve your situation.
Comment 6 Bug Zapper 2008-11-25 23:30:28 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Jack Tanner 2008-12-02 17:04:55 EST
Created attachment 325434 [details]
Xorg.0.log generated using an xorg.conf

Upgraded to F10, still no KMS love

kernel-2.6.27.7-134.fc10.x86_64
xorg-x11-server-common-1.5.3-5.fc10.x86_64
xorg-x11-drv-ati-6.9.0-61.fc10.x86_64
Comment 8 Jack Tanner 2008-12-02 17:05:46 EST
Created attachment 325435 [details]
xorg.conf
Comment 9 Jack Tanner 2008-12-19 12:06:47 EST
Created attachment 327464 [details]
Xorg.0.log generated using an xorg.conf

Still no KMS under 

kernel-2.6.27.9-163.fc10.x86_64
xorg-x11-server-common-1.5.3-6.fc10.x86_64
xorg-x11-drv-ati-6.9.0-62.fc10.x86_64

New Xorg.0.conf attached
Comment 10 Bug Zapper 2009-11-18 03:42:36 EST
This message is a reminder that Fedora 10 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 10.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '10'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 10's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 10 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 11 Bug Zapper 2009-12-18 01:42:01 EST
Fedora 10 changed to end-of-life (EOL) status on 2009-12-17. Fedora 10 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.