Bug 469216 - LSPP labels are not on output when CUPS is in configure in LSPP mode
LSPP labels are not on output when CUPS is in configure in LSPP mode
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: cups (Show other bugs)
5.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: Tim Waugh
desktop-bugs@redhat.com
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-30 12:51 EDT by Tim Waugh
Modified: 2009-01-20 16:59 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 16:59:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Waugh 2008-10-30 12:51:02 EDT
+++ This bug was initially created as a clone of Bug #468442 +++

Description of problem:
Printouts do not have the correct banners on them.  The banner has a leading 'LSPP:' and it does not wrap when the label is too long.

Version-Release number of selected component (if applicable):
cups-1.3.9-1

How reproducible:
Whenever cups is configured to be in LSPP mode

Steps to Reproduce:
1. Set CLASSIFICATION to selinux in /etc/cups/cupsd.conf
2. restart the cups service
3. print something, it won't have the proper banners
  
Actual results:
A printout without the proper security label.

Expected results:
The printout should have a per page security label.

Additional info:
filter/common.c has a write_label_prolog() which used to be called by pstops.c, now pstops.c has its own WriteLabelProlog() which also need to be patched.

--- Additional comment from twaugh@redhat.com on 2008-10-30 10:43:57 EDT ---

Thanks for the report.  I've built a cups-1.3.9-3.fc10 package here:
http://koji.fedoraproject.org/koji/buildinfo?buildID=68106

It seems to behave correctly for me.  Are you able to test these packages?  Fedora 10 is frozen now but I'd like to get this fix in an update.
Comment 4 Tim Waugh 2008-10-31 05:24:31 EDT
FWIW, the fix that went into cups-1.3.9-3.fc10 is reported to work correctly.
Comment 12 errata-xmlrpc 2009-01-20 16:59:02 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-0201.html

Note You need to log in before you can comment on or make changes to this bug.