Bug 469221 - Satellite restart doesn't work anymore from webUi
Satellite restart doesn't work anymore from webUi
Status: CLOSED NOTABUG
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI (Show other bugs)
530
All Linux
medium Severity medium
: ---
: ---
Assigned To: Justin Sherrill
Brandon Perkins
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-30 13:22 EDT by Justin Sherrill
Modified: 2008-10-30 23:03 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-30 13:39:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Justin Sherrill 2008-10-30 13:22:53 EDT
Since we've gotten rid of the 'rhn-satellite' init script, the webUI's restart no longer works.

Currently it still calls 

/usr/sbin/rhn-satellite-restart-silent  (we did this do to an issue in java that caused bad things if the command was outputting data).

This script still calls '/etc/init.d/rhn-satellite restart' which no longer exists.  We should just change the rhn-satellite-restart-silent script to call '/sbin/rhn-satellite restart'.
Comment 1 Justin Sherrill 2008-10-30 13:25:13 EDT
actually, it's not rhn-satellite-restart-client, its:

/sbin/rhn-sat-restart-silent
Comment 2 Justin Sherrill 2008-10-30 13:39:39 EDT
actually, this is working fine.  Not sure what i was seeing..

Note You need to log in before you can comment on or make changes to this bug.