Bug 469229 - xdg-utils seems broken as reported on this site http://awn.planetblur.org/index.php?shard=forum&action=g_reply&ID=2070#24172
xdg-utils seems broken as reported on this site http://awn.planetblur.org/ind...
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: pyxdg (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
http://awn.planetblur.org/index.php?s...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-30 13:51 EDT by Ashwin
Modified: 2008-10-31 11:51 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-31 06:24:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ashwin 2008-10-30 13:51:43 EDT
Description of problem:


Version-Release number of selected component (if applicable):1.0.2-4.fc9


How reproducible:
Installing the Avant Window Navigator (avant-window-navigator) and then trying to run the manager by typing awn-manager at the terminal

Steps to Reproduce:
1.Install Avant Window Manager (http://awn-project.org/) by yum install avant-window-manager
2.Try to run the manager toll for the software - awn-manager
  
Actual results:
Fails silently if accessed using the menu. In the terminal, the following output is generated

Traceback (most recent call last):
  File "/usr/bin/awn-manager", line 46, in <module>
    from awnApplet import awnApplet
  File "/usr/share/avant-window-navigator/awn-manager/awnApplet.py", line 38, in <module>
    from xdg.DesktopEntry import DesktopEntry
  File "/usr/lib/python2.5/site-packages/xdg/DesktopEntry.py", line 184
    self.errors.append("Group may either have OnlyShowIn or NotShowIn, but not both")
       ^
IndentationError: expected an indented block



Expected results:
Should open up the manager console

Additional info:
Comment 1 Ashwin 2008-10-30 14:02:14 EDT
I myself tried to open the file /usr/lib/python2.5/site-packages/xdg/DesktopEntry.py and added an indent at line number 184 and it worked.
Comment 2 Rex Dieter 2008-10-30 14:04:48 EDT
Reassigning to pyxdg
Comment 3 Fedora Update System 2008-10-30 15:53:53 EDT
pyxdg-0.16-1.fc8 has been submitted as an update for Fedora 8.
http://admin.fedoraproject.org/updates/pyxdg-0.16-1.fc8
Comment 4 Fedora Update System 2008-10-30 15:53:56 EDT
pyxdg-0.16-1.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/pyxdg-0.16-1.fc9
Comment 5 Tom "spot" Callaway 2008-10-30 15:54:25 EDT
I've also requested an F10 override for this fix, and sent the patch upstream.
Comment 6 Fedora Update System 2008-10-31 06:24:43 EDT
pyxdg-0.16-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2008-10-31 06:25:45 EDT
pyxdg-0.16-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Ashwin 2008-10-31 11:51:06 EDT
I installed the updated package from
http://koji.fedoraproject.org/koji/buildinfo?buildID=68135

and the awn-manager is working (still!).

This was my first firsthand experience of submitting a bug to the community and it resolves... zap!

Fabulous. Great going guys.

Note You need to log in before you can comment on or make changes to this bug.