Bug 469259 - [enh] enable domain names as gateway in routers table
[enh] enable domain names as gateway in routers table
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-30 16:59 EDT by Luo Bin
Modified: 2013-05-07 11:25 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-07 11:25:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Luo Bin 2008-10-30 16:59:44 EDT
Description of problem:
1.domain name problem
Right-click on the icon -->edit connection -->ipv4 setting --->routers 
just here,the content of gateway must be an IP address,but sometimes I needs a domain name here to put in .

2.another problem about saving the config:
Right-click on the icon -->edit connection -->ipv4 setting --->routers  -->add
here,if you has already typed something into the box then do some window switching actions,the date you input will lost.It will not be saved.

Version-Release number of selected component (if applicable):
NetworkManager-gnome-0.7.0-0.11.svn4229.fc10.i386
NetworkManager-0.7.0-0.11.svn4229.fc10.i386
NetworkManager-glib-0.7.0-0.11.svn4229.fc10.i386

How reproducible&Steps to Reproduce:
 Plesase referred to the Description of problem above

  
Actual results:


Expected results:


Additional info:
Comment 1 Dan Williams 2008-11-02 17:48:44 EST
Bill: does the normal initscript stuff ifup-routes accept hostnames as route gateways?

Luo Bin: in what cases exactly do you need a domain name there?
Comment 2 Luo Bin 2008-11-02 18:22:18 EST
Like some VPN services ,the gateway expressed in dynamic domain.
You can't assign a certain IP as a gateway because the IP resolving from the domain changes every time!
Comment 3 Bill Nottingham 2008-11-03 14:20:03 EST
Dan, an older format we support is:

    cat "$file" ; echo ; } | while read line; do
    if <line is not blank or a comment> ; then
          /sbin/ip route add $line
    fi

So, yes, that 'accepts' hostnames, if you can call it that.
Comment 4 Bug Zapper 2008-11-25 23:31:08 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Charles R. Anderson 2008-11-29 16:07:04 EST
For a "normal" default gateway, it seems unsafe to use a hostname, because the DNS server could be off the local subnet and unreachable until the default gateway is set.
Comment 6 Niels Haase 2009-04-13 07:53:03 EDT
Changing title to reflect the enhancement request.
Comment 7 Niels Haase 2009-06-19 17:39:54 EDT
This bug has been triaged

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 8 Pavel Šimerda (pavlix) 2013-05-07 11:25:31 EDT
If still interested, please file upstream.

Note You need to log in before you can comment on or make changes to this bug.