Bug 469269 - mount -o ro of live usb device fails
mount -o ro of live usb device fails
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-30 18:57 EDT by Orion Poplawski
Modified: 2008-10-31 12:34 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-31 12:34:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace -f of mount -o ro /dev/sdb1 /mnt/live (9.56 KB, text/plain)
2008-10-30 18:57 EDT, Orion Poplawski
no flags Details

  None (edit)
Description Orion Poplawski 2008-10-30 18:57:02 EDT
Created attachment 321994 [details]
strace -f of mount -o ro /dev/sdb1 /mnt/live

Description of problem:

Built a Live USB stick of the latest rawhide with the latest livecd tools.  It fails to mount the persistent home directory because of the following:

mount -o ro /dev/sdb1 /mnt/live

fails with:

mount: /dev/sdb1 already mounted or /mnt/live busy.

Strace shows:

3117  mount("/dev/sdb1", "/mnt/live", "vfat", MS_MGC_VAL|MS_RDONLY, NULL) = -1 EBUSY (Device or resource busy)

However, /dev/sdb1 is not mounted, and /mnt/live is not busy.  mount with the -o ro works:

3119  mount("/dev/sdb1", "/mnt/live", "vfat", MS_MGC_VAL, NULL) = 0

Version-Release number of selected component (if applicable):
2.6.27.4-58.fc10.i686

How reproducible:
everytime
Comment 1 Jeremy Katz 2008-10-30 22:19:11 EDT
If you're running off of the live image, then /dev/sdb1 is definitely already mounted since that's where you'd be running from.  Do you have a persistent overlay also?

Also, are you using the current configs in the spins-kickstart repo?  They should be doing
  mount -o ro /dev/live /mnt/live || mount /dev/live /mnt/live
to try a rw mount if ro fails
Comment 2 Orion Poplawski 2008-10-31 11:22:46 EDT
Have persistent overlay.

So, I guess if /dev/sdb1 is already mounted somewhere r/w, it can't get mounted again r/o?

I was using configs from fedora-release, I'll track down spins-kickstart...
Comment 3 Jeremy Katz 2008-10-31 12:34:04 EDT
Yep, that's exactly it.

Note You need to log in before you can comment on or make changes to this bug.