Bug 469277 - /etc/profile.d/colorls.* uses "tput" command, coreutils missing Requires: ncurses
/etc/profile.d/colorls.* uses "tput" command, coreutils missing Requires: ncu...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: coreutils (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ondrej Vasik
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F10Target
  Show dependency treegraph
 
Reported: 2008-10-30 21:35 EDT by Charles R. Anderson
Modified: 2008-11-03 12:34 EST (History)
3 users (show)

See Also:
Fixed In Version: coreutils-6.12-17.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-03 12:34:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Charles R. Anderson 2008-10-30 21:35:55 EDT
Description of problem:

/etc/profile.d/colorls.{sh,csh} uses the "tput" command.  "tput" is provided by ncurses.  ncurses isn't explicitly required by coreutils, and nothing else seems to be pulling it in on a default F10 install.  Hence, when new tcsh shells are spawned, I get an error:

tput: Command not found.

Other commands in ncurses are also pretty basic and should probably always be installed, like "clear" and "reset".

Version-Release number of selected component (if applicable):
coreutils-6.12-16.fc10.i386
Comment 1 Ondrej Vasik 2008-10-31 02:46:15 EDT
Thanks for report, I thought ncurses package was on exception list(no requires needed) as it was required by bash and coreutils at least (I guess even more packages). Will check that - and possibly add this Requires: ncurses.
Comment 2 Ondrej Vasik 2008-11-03 06:35:55 EST
Commited to CVS and built as coreutils-6.12-17.fc10 ... Tagging for F10-final requested at https://fedorahosted.org/rel-eng/ticket/956 - waiting for decision.
Comment 3 Ondrej Vasik 2008-11-03 12:34:30 EST
Tagged -> fixed ...

Note You need to log in before you can comment on or make changes to this bug.