Bug 469282 - python-paver should Require: python-devel
python-paver should Require: python-devel
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: python (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: James Antill
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-30 22:17 EDT by Ian Weller
Modified: 2009-02-15 15:29 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-15 15:29:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ian Weller 2008-10-30 22:17:26 EDT
python-paver requires python-devel for most things to work. so it should be a requires.

(see http://koji.fedoraproject.org/koji/getfile?taskID=913072&name=build.log)
Comment 1 Toshio Ernie Kuratomi 2008-11-01 12:07:27 EDT
A couple thoughts:

* python-devel shouldn't be required by paver an more than glibc-devel should be required by make.
* This is actually a distutils requirement rather than a paver requirement.

James, this came up before during Jeremy's maintenance of python WRT setuptools::
  https://bugzilla.redhat.com/show_bug.cgi?id=251645#c18

The basic problem is that distutils uses the Makefile and those pyconfig*.h files as data sources.  So certain distutils and setuptools (and now paver) commands fail when those files are not present.

Do you think that moving those files to the python package would be okay?
Comment 2 James Antill 2008-11-03 11:56:45 EST
It won't be the end of the world if python itself includes those 3 .h files, my biggist worries are:

1. This is the wrong fix, and the tools should be fixed.

2. This would be pretty unique, cpufrequtils is the only "normal" package I can find that puts .h files into /usr/include ... and that looks like a packaging bug.
Comment 3 Toshio Ernie Kuratomi 2008-11-19 19:03:35 EST
Ian, sorry, I've decided I'm not going to have paver depend on python-devel for the reasons I gave in c#1.  We can see what upstream python has to say, though.  If they're willing to change where the data being read from the Makefile and pyconfig.h is located then we're all set.  If not we'll have to see.

I've opened a bug upstream:
  http://bugs.python.org/issue4359
Comment 4 Bug Zapper 2008-11-25 23:31:41 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Ian Weller 2009-02-15 15:29:27 EST
I'm going to close this as WONTFIX so I can get it out of my bugs list. Thanks for reporting upstream, Toshio.

Note You need to log in before you can comment on or make changes to this bug.