This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 469289 - AVCs
AVCs
Status: CLOSED DUPLICATE of bug 469519
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
8
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-30 23:43 EDT by Matthew Saltzman
Modified: 2008-11-02 17:49 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-02 17:49:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Saltzman 2008-10-30 23:43:21 EDT
Description of problem:
Several new NetworkManager AVCs from the latest selinux-policy-targeted.

Version-Release number of selected component (if applicable):
NetworkManager-0.7.0-0.11.svn4022.4.fc8.x86_64
selinux-policy-targeted-3.0.8-121.fc8.noarch

How reproducible:
Always

Steps to Reproduce:
1. Connect using NetowrkManager
2.
3.
  
Actual results:
AVCs

Expected results:
No AVCs

Additional info:
Raw Audit Messages :host=valkyrie.localdomain type=AVC msg=audit(1225413741.428:116): avc: denied { execute } for pid=29980 comm="NetworkManager" name="nscd" dev=dm-0 ino=2860294 scontext=system_u:system_r:NetworkManager_t:s0 tcontext=system_u:object_r:nscd_exec_t:s0 tclass=file 

host=valkyrie.localdomain type=SYSCALL msg=audit(1225413741.428:116): arch=c000003e syscall=59 success=no exit=-13 a0=259d410 a1=25a19b0 a2=7ffff96e13f0 a3=0 items=0 ppid=3802 pid=29980 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="NetworkManager" exe="/usr/sbin/NetworkManager" subj=system_u:system_r:NetworkManager_t:s0 key=(null) 

On boot, I also saw:

Raw Audit Messages :host=valkyrie.localdomain type=AVC msg=audit(1225380583.342:13): avc: denied { read } for pid=3809 comm="nm-system-setti" name="PolicyKit" dev=dm-0 ino=789970 scontext=system_u:system_r:NetworkManager_t:s0-s0:c0.c1023 tcontext=system_u:object_r:hald_var_lib_t:s0 tclass=dir

host=valkyrie.localdomain type=SYSCALL msg=audit(1225380583.342:13): arch=c000003e syscall=254 success=no exit=-13 a0=6 a1=3144c0914e a2=306 a3=36301529f0 items=0 ppid=3808 pid=3809 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="nm-system-setti" exe="/usr/sbin/nm-system-settings" subj=system_u:system_r:NetworkManager_t:s0-s0:c0.c1023 key=(null) 

With the previous selinux=policy-targeted, I also had one occurrence of:

Raw Audit Messages :host=valkyrie.localdomain type=AVC msg=audit(1225366083.32:750): avc: denied { signull } for pid=10315 comm="nm-vpnc-service" scontext=system_u:system_r:NetworkManager_t:s0 tcontext=system_u:system_r:vpnc_t:s0 tclass=process 

host=valkyrie.localdomain type=SYSCALL msg=audit(1225366083.32:750): arch=c000003e syscall=62 success=no exit=-13 a0=2850 a1=0 a2=2850 a3=1 items=0 ppid=3165 pid=10315 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="nm-vpnc-service" exe="/usr/libexec/nm-vpnc-service" subj=system_u:system_r:NetworkManager_t:s0 key=(null)
Comment 1 Matthew Saltzman 2008-10-31 07:36:58 EDT
Update:  The nscd violation occurs when I stop and start NetworkManager-vpnc.

Sorry for the misinformation.

The likely culprit as far as I can see is:

$ ls -lZ /usr/sbin/nscd
-rwxr-xr-x  root root system_u:object_r:nscd_exec_t:s0 /usr/sbin/nscd
Comment 2 Dan Williams 2008-11-02 17:49:37 EST

*** This bug has been marked as a duplicate of bug 469519 ***

Note You need to log in before you can comment on or make changes to this bug.