Bug 469290 - Massive USB Slow Down after hours of computer use
Massive USB Slow Down after hours of computer use
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.2
i386 Linux
medium Severity low
: rc
: ---
Assigned To: Pete Zaitcev
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-30 23:49 EDT by Todd
Modified: 2013-06-24 13:12 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-24 13:12:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Todd 2008-10-30 23:49:16 EDT
Hi All,

I backup to a Transcend JF110 USB thumb drive. It has a 25 MB/s write speed.
It is very fast. It backups up 940 MB in 1 minute and 32 seconds. Except
if I have been running my computer all day, in which case it takes 92 minutes. 

I have been rebooting before doing my backups as a workaround.  I get my speed
back after the reboot.

Programs that I run: firefox, thunderbird, gimp, open office 3, thunar, XFce,
Wine, Virtual Box 1.6.6 and 2.0.2 (Guest: XP Pro sp3: word pro, 123,
approach, Acrobat 8 pro, Go To Assist Express)

Many thanks,
-T
Comment 1 Pete Zaitcev 2008-11-21 08:26:38 EST
Bug has no I-T number, I'm working with the requestor out of band.
Comment 2 Todd 2008-12-12 18:23:37 EST
Steps to reproduce:

1)  start a "dump" from my primary partition (/dev/sda1) to my removable
SATA (not eSata) backup drive (/dev/sdb2)

2)  let "dump" run for about ten minutes (full dump takes 1hr 45min to run)

3)  stop the "dump" with a <Ctrl><C>

After that, a 940 MB copy from /dev/sda2 to my USB stick will drop from
1 min 32 sec to 92 minutes.  (Rebooting always fixes it.)
Comment 3 Todd 2008-12-12 18:24:53 EST
940 MB copy from /dev/sda2 
                 ^^^^^sdb2

Ooops
Comment 4 Todd 2009-03-02 21:18:35 EST
It is doing it right now.  I can not remember what test you wanted me to do when the symptom appears.  Would you give me a list so as next time I can take some data for you?

Many thanks,
-T
Comment 5 Todd 2009-03-09 21:25:28 EDT
Hi All,

   Just got a posting over on CentOS forum:
http://www.centos.org/modules/newbb/viewtopic.php?post_id=70121&topic_id=18798&forum=37#forumpost70121

   The writer was checking out why rhel 3 and rhel 5 performed so differently on large file transfers.  He found that the dirty_background_ratio and dirty_ratio were set to 50 under rhel3 and 2 and 8 respectively on rhel5.  He set both rhel5's to 50 and problem solved.  The is what he did:


root@ddb04>cat /proc/sys/vm/dirty_background_ratio
2

root@ddb04>cat /proc/sys/vm/dirty_ratio
8

root@ddb04>echo 50 > /proc/sys/vm/dirty_background_ratio
root@ddb04>echo 50 > /proc/sys/vm/dirty_ratio


Mine are set to:
# cat /proc/sys/vm/dirty_background_ratio
10

# cat /proc/sys/vm/dirty_ratio
40


Could this problem be solved just by changing these two values?

-T
Comment 6 Todd 2009-11-30 02:12:54 EST
Hi All,

I can not reproduce this problem since upgrading to CentOS 5.4.  Did you guys fix some USB bugs in 5.4?

Anyway, you can close this as "works in 5.4".  (I tried, but it got mad at me.)

Many, many thanks,
-T

Note You need to log in before you can comment on or make changes to this bug.