Bug 469355 - broken cflags in %{libdir}/pkgconfig/rpm.pc
broken cflags in %{libdir}/pkgconfig/rpm.pc
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
10
All Linux
medium Severity high
: ---
: ---
Assigned To: Panu Matilainen
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-31 09:57 EDT by Ralf Corsepius
Modified: 2009-01-07 04:21 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-07 04:21:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ralf Corsepius 2008-10-31 09:57:42 EDT
Description of problem:

%{libdir}/pkgconfig/rpm.pc is broken:

# pkg-config --cflags rpm
-I/usr/include/  

Note the '/' at the end of this line.

Version-Release number of selected component (if applicable):
rpm-4.6.0-0.rc1.6.i386
  
Actual results:
$(pkg-config --cflags rpm) returns a bogus value.

Expected results:
$(pkg-config --cflags rpm) should return nothing.

Additional info:
pkg-config --cflags must not return -I/usr/include rsp. -I/usr/include/,
because this disturbs the compiler's default/system include path (/usr/include is implicitly searched).

pkg-config even filters out /usr/include.

rpm's rpm.pc circumvents this filtering by carrying and explicit "/" in its
Cflags: -I${includedir}/
Comment 1 Panu Matilainen 2008-10-31 11:48:51 EDT
Right.. fixed upstream, Fedora will get it on the eventual update to 4.6.0 final (this is hardly important enough to patch separately and break the freeze)
Comment 2 Ralf Corsepius 2008-10-31 12:03:57 EDT
(In reply to comment #1)
> Right.. fixed upstream, Fedora will get it on the eventual update to 4.6.0
> final (this is hardly important enough to patch separately and break the
> freeze)
Sigh - You are vastly underestimating the potential of such bugs.

The problem with it: It's unlikely to hit, because it's unlikely any package in fedora will use rpm's pkgconfig. But if it should hit, the effects likely will be dramatic.

Wrt. the freeze - Shall the rel-eng have an interesting life with it.
Comment 3 Panu Matilainen 2008-11-03 03:03:00 EST
We have very different ideas of what a dramatic bug is obviously.
This wont eat anybodys hard drive for breakfast or cause failed installations/upgrades - that's dramatic for me. There are no current users of rpm's pkg-config so at the worst it affects somebody trying to compile (new) software using librpm C API and even then it's easily avoidable by not using pkg-config. It's a bug and will be fixed, that's all there is to it.
Comment 4 Ralf Corsepius 2008-11-03 03:47:27 EST
(In reply to comment #3)
> We have very different ideas of what a dramatic bug is obviously.
Apparently. 

Your attitude is the typical ignorance RH folks expose when it comes to bugs which don't affect "end-users".

> This wont eat anybodys hard drive for breakfast or cause failed
> installations/upgrades
Right - It won't hurt "normal endusers", but it will hurt packagers and developers.

> - that's dramatic for me. There are no current users of
> rpm's pkg-config
Wrong. We are talking about a *-devel package
=> it will hurt all developers who are using this newer rpm.

Acceptable for RHEL, but unacceptable for a distro aiming at an audience consisting of developers.

> so at the worst it affects somebody trying to compile (new)
> software using librpm C API and even then it's easily avoidable by not using
> pkg-config.
Correct. You are wasting one key feature, which would have helped to make rpm.org's attractive.
Comment 5 Panu Matilainen 2008-11-03 04:40:33 EST
Sigh. I already said it will be fixed in rpm 4.6.0 final, end of story.
Comment 6 Ralf Corsepius 2008-11-03 21:41:20 EST
Bug is unfixed in Fedora. Trying to reopen.
Comment 7 Bug Zapper 2008-11-25 23:32:49 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Panu Matilainen 2008-11-29 12:52:37 EST
Fixed in rawhide, F10 will have it as an update after a bit of testing of 4.6.0-rc2 in rawhide.
Comment 9 Fedora Update System 2008-12-12 14:14:37 EST
rpm-4.6.0-0.rc3.1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/rpm-4.6.0-0.rc3.1.fc10
Comment 10 Fedora Update System 2008-12-17 19:34:41 EST
rpm-4.6.0-0.rc3.1.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update rpm'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2008-11332
Comment 11 Fedora Update System 2009-01-07 04:20:41 EST
rpm-4.6.0-0.rc3.1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.