Bug 469382 - RFE: iSCSI chap authentication shown optional
RFE: iSCSI chap authentication shown optional
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ales Kozumplik
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks: AnacondaUI
  Show dependency treegraph
 
Reported: 2008-10-31 11:31 EDT by James Laska
Modified: 2014-09-30 19:38 EDT (History)
2 users (show)

See Also:
Fixed In Version: anaconda-15.2
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-07 11:48:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Laska 2008-10-31 11:31:51 EDT
Description of problem:

Both in graphical and text-mode the iSCSI volume add dialogs make it appear that CHAP is required. 

Version-Release number of selected component (if applicable):
anaconda 11.4.1.53

How reproducible:


Steps to Reproduce:
1. Boot into graphical or text-mode anaconda
2. At partitioning, add an iSCSI volume
  
Actual results:

             ┌───────────┤ Configure iSCSI Parameters ├───────────┐
             │                                                    │
             │ To use iSCSI disks, you must provide the address   │
             │ of your iSCSI target and the iSCSI initiator       │
             │ name you've configured for your host.              │
             │                                                    │
             │     Target IP Address     192.168.33.219______     │
             │     iSCSI Initiator Name  iqn.rhel5.ppc_______     │
             │     CHAP username         ____________________     │
             │     CHAP password         ____________________     │
             │     Reverse CHAP username ____________________     │
             │     Reverse CHAP password ____________________     │
             │                                                    │
             │         ┌────┐                 ┌────────┐          │
             │         │ Ok │                 │ Cancel │          │
             │         └────┘                 └────────┘          │
             │                                                    │
             │                                                    │
             └────────────────────────────────────────────────────┘

Expected results:

             ┌───────────┤ Configure iSCSI Parameters ├───────────┐
             │                                                    │
             │ To use iSCSI disks, you must provide the address   │
             │ of your iSCSI target and the iSCSI initiator       │
             │ name you've configured for your host.              │
             │                                                    │
             │     Target IP Address     192.168.33.219______     │
             │     iSCSI Initiator Name  iqn.rhel5.ppc_______     │
             │                                                    │
             │     [ ] Use CHAP authentication?                   │
             │         ┌────┐                 ┌────────┐          │
             │         │ Ok │                 │ Cancel │          │
             │         └────┘                 └────────┘          │
             └────────────────────────────────────────────────────┘

             ┌───────────┤ CHAP Authentication ├──────────────────┐
             │                                                    │
             │     CHAP username         ____________________     │
             │     CHAP password         ____________________     │
             │     Reverse CHAP username ____________________     │
             │     Reverse CHAP password ____________________     │
             │         ┌────┐                 ┌────────┐          │
             │         │ Ok │                 │ Cancel │          │
             │         └────┘                 └────────┘          │
             └────────────────────────────────────────────────────┘

Or maybe even still in one dialog?

             ┌───────────┤ Configure iSCSI Parameters ├───────────┐
             │                                                    │
             │ To use iSCSI disks, you must provide the address   │
             │ of your iSCSI target and the iSCSI initiator       │
             │ name you've configured for your host.              │
             │                                                    │
             │     Target IP Address     192.168.33.219______     │
             │     iSCSI Initiator Name  iqn.rhel5.ppc_______     │
             │                                                    │
             │ If needed, you may configure CHAP Authentication   │
             │ below (optional).                                  │
             │                                                    │
             │     CHAP username         ____________________     │
             │     CHAP password         ____________________     │
             │     Reverse CHAP username ____________________     │
             │     Reverse CHAP password ____________________     │
             │                                                    │
             │         ┌────┐                 ┌────────┐          │
             │         │ Ok │                 │ Cancel │          │
             │         └────┘                 └────────┘          │
             │                                                    │
             │                                                    │
             └────────────────────────────────────────────────────┘

Additional info:

 * In graphical mode, it would make sense as an expanding section widget.  Not sure what hte widget is called, but when clicked, it expands below to show more dialog options.

 * This is a NIT ... I know.  I know text-mode divergence isn't a good thing too.
Comment 1 Ales Kozumplik 2010-10-19 09:52:02 EDT
A series of patches that improve the situation for both TUI and GUI are present since anaconda-15.2.

The two key patches are:
8123165b3163b4a70066b11091ac309cc91c4cb8
0a2b2513c56fcf56b250ae83dba14bc65044b73f

Note You need to log in before you can comment on or make changes to this bug.