Bug 469385 - utf8 error from cumin
utf8 error from cumin
Status: CLOSED DUPLICATE of bug 467014
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-qmf (Show other bugs)
1.0
All Linux
medium Severity medium
: 1.1
: ---
Assigned To: messaging-bugs
Jeff Needle
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-31 11:44 EDT by Matthew Farrellee
Modified: 2011-08-12 12:01 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-11 12:10:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Farrellee 2008-10-31 11:44:42 EDT
# rpm -q cumin
cumin-0.1.2690-1.el5

[root@north-16 ~]# cumin --addr 0.0.0.0
Exception in thread Thread-15:
Traceback (most recent call last):
  File "/usr/lib64/python2.4/threading.py", line 442, in __bootstrap
    self.run()
  File "/usr/lib64/python2.4/threading.py", line 422, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib/python2.4/site-packages/qpid/queue.py", line 82, in run
    self.listener(o)
  File "/usr/lib/python2.4/site-packages/qpid/management.py", line 203, in replyCb
    self.rcb (self, msg)
  File "/usr/lib/python2.4/site-packages/qpid/management.py", line 381, in replyCb
    self.handleMethodReply (ch, codec, hdr[1])
  File "/usr/lib/python2.4/site-packages/qpid/management.py", line 537, in handleMethodReply
    sText  = str (codec.read_str16 ())
  File "/usr/lib/python2.4/site-packages/qpid/codec010.py", line 127, in read_str16
    return self.read_vbin16().decode("utf8")
  File "/usr/lib64/python2.4/encodings/utf_8.py", line 16, in decode
    return codecs.utf_8_decode(input, errors, True)
UnicodeDecodeError: 'utf8' codec can't decode byte 0xa8 in position 11: unexpected code byte

cumin had two registered brokers, mrg2 and north-15. i cannot tell where the message that caused this problem was coming from though.
Comment 1 Matthew Farrellee 2008-10-31 11:49:52 EDT
this appears to happen when clicking on the Grid tab when cumin is receiving data from mrg2
Comment 2 Ted Ross 2008-11-11 12:10:33 EST

*** This bug has been marked as a duplicate of bug 467014 ***

Note You need to log in before you can comment on or make changes to this bug.