Bug 469408 - PA, skype, 64-bit: "E: shm.c: Invalid shared memory segment size"
PA, skype, 64-bit: "E: shm.c: Invalid shared memory segment size"
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-31 13:29 EDT by Tom London
Modified: 2008-11-01 17:32 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-01 17:32:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom London 2008-10-31 13:29:18 EDT
Description of problem:
Not sure this is a bug (so feel free to close...):

I'm running on Thinkpad X61 with x86_64 kernel; I think I have skype 2.0 "working" with pulseaudio by doing the following:

1. Downloaded "OSS static" version
2. installed a host of i386 libraries/packages:

Oct 30 09:01:46 Installed: alsa-lib-1.0.18-6.rc3.fc10.i386
Oct 30 09:03:49 Installed: libXv-1.0.4-1.fc10.i386
Oct 30 09:04:40 Installed: libXScrnSaver-1.1.3-1.fc10.i386
Oct 30 09:06:14 Installed: 2:libogg-1.1.3-9.fc9.i386
Oct 30 09:06:15 Installed: flac-1.2.1-4.fc9.i386
Oct 30 09:06:16 Installed: libsndfile-1.0.17-6.fc10.i386
Oct 30 09:06:17 Installed: pulseaudio-utils-0.9.13-4.fc10.i386

[And pulseaudio-libs.i386]

3. created a "paskype" command in /usr/bin to allow it to run in execmem_t domain:
       cp /usr/bin/padsp /usr/bin/paskype
       chcon -t unconfined_execmem_exec_t /usr/bin/paskype

Now, 'paskype "path to OSS static skype"' appears to work.

But, I get scads of the following messages:

E: shm.c: Invalid shared memory segment size
E: shm.c: Invalid shared memory segment size
E: shm.c: Invalid shared memory segment size
E: shm.c: Invalid shared memory segment size
E: shm.c: Invalid shared memory segment size
E: shm.c: Invalid shared memory segment size
E: shm.c: Invalid shared memory segment size

I think these are being generated when skype trys to play the "phone is ringing" sound clip.  I don't think I get these when "real human audio" is played.

Worth tracking down?  [I'm asking if this is exposing a PA issue, not a skype issue.]

Version-Release number of selected component (if applicable):
pulseaudio-libs-0.9.13-4.fc10.x86_64
pulseaudio-esound-compat-0.9.13-4.fc10.x86_64
pulseaudio-core-libs-0.9.13-4.fc10.x86_64
pulseaudio-module-x11-0.9.13-4.fc10.x86_64
pulseaudio-module-gconf-0.9.13-4.fc10.x86_64
pulseaudio-libs-glib2-0.9.13-4.fc10.x86_64
pulseaudio-utils-0.9.13-4.fc10.x86_64
pulseaudio-utils-0.9.13-4.fc10.i386
pulseaudio-libs-0.9.13-4.fc10.i386
pulseaudio-0.9.13-4.fc10.x86_64


How reproducible:
Every time....

Steps to Reproduce:
1. Install as above
2. Connect to "Skype Test Call"
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Lennart Poettering 2008-11-01 17:32:20 EDT
Fixed in pulseaudio-0.9.13-6

Note You need to log in before you can comment on or make changes to this bug.