Bug 469430 - Groups support filters group list to those in categories
Groups support filters group list to those in categories
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-packagekit (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-31 15:57 EDT by James Antill
Modified: 2009-04-15 12:34 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-15 12:34:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Antill 2008-10-31 15:57:48 EDT
Description of problem:
"yum grouplist" lists all groups user_visible groups
Turning on the "Use category group list" only shows those groups that are in a Category.
 This misses "Fedora Eclipse" from the Fedora repos. ... and anything from a local repo. that isn't in a Category.
Comment 1 Richard Hughes 2008-11-06 06:04:06 EST
Sorry, I don't understand -- do you think the PK group list is missing packages or categories? Do you have any idea how the yum code gets a different answer to PK?
Comment 2 James Antill 2008-11-06 11:01:07 EST
PK is missing groups.

The reason is that it does a strict two level tree of categories on the top level and then groups under those categories. But some of the groups aren't in a category. Yum just lists groups, so doesn't care ... in fact without the yum-categories plugin you can't even see the categories data from the yum Cmd line UI.
Comment 3 Richard Hughes 2008-11-07 04:53:36 EST
Ohh, right. Can we add those extra groups to an "Other" category perhaps, or is is this something that has to be hardcoded in PackageKit?
Comment 4 James Antill 2008-11-07 10:27:30 EST
Doing that automatically in the yum API would be a bad idea, atm. you have:

        cats =  [cat.categoryid for cat in self.yumbase.comps.categories]
        for cat in cats:
            grps = self.comps.get_groups(cat)
            for grp_id in grps:
                grp = self.yumbase.comps.return_group(grp_id)
                if grp:

...so the only way to make it "automagically" work is for the yum API to create a fake category which has all the groups in it that aren't in any other category.
 Pirut uses "Uncategorized".
Comment 5 Tim Lauridsen 2008-11-07 10:53:03 EST
I have added some changes to the pk yumComps to add all non categorized groups to an 'other' category

so self.comps.get_groups('other') will return all the non categorized groups.

I have not made yumBacked code yet.

but running 'sudo yumComps.py' will show the groups.

Note You need to log in before you can comment on or make changes to this bug.