This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 469452 - akregator crashes on startup with an imported feeds.opml
akregator crashes on startup with an imported feeds.opml
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kdepim (Show other bugs)
10
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-31 18:58 EDT by Sebastian Vahl
Modified: 2009-03-17 08:33 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-17 08:33:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Ouput of KDE's crash manager (3.86 KB, text/plain)
2008-10-31 19:07 EDT, Sebastian Vahl
no flags Details
second try after removing feeds.opml (3.34 KB, application/octet-stream)
2008-10-31 19:10 EDT, Sebastian Vahl
no flags Details
third try after removing feeds.opml (3.74 KB, application/octet-stream)
2008-10-31 19:10 EDT, Sebastian Vahl
no flags Details
feeds.opml with some problematic feeds (6.24 KB, application/octet-stream)
2008-10-31 19:42 EDT, Sebastian Vahl
no flags Details
crash log created for the comment above (3.73 KB, application/octet-stream)
2008-10-31 19:43 EDT, Sebastian Vahl
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 164265 None None None Never

  None (edit)
Description Sebastian Vahl 2008-10-31 18:58:57 EDT
Description of problem:
akgegator crashs on startup with an imported feeds.opml from the KDE3 version of akgregator.


Version-Release number of selected component (if applicable):
kdepim-4.1.2-4.fc10.x86_64

How reproducible:
everytime on startup

Steps to Reproduce:
1. install kdepim
2. import the feeds.opml (attached)
3. update all feeds
3. move the imported folders from the "imported feeds"-folder to the top folder
4. re-start akregator

  
Actual results:
crash

Expected results:
no crash

Additional info:
I'll attach my problematic feeds.opml tomorrow morning after I was able to have a look at it because of private feeds.
Comment 1 Sebastian Vahl 2008-10-31 19:07:40 EDT
Created attachment 322144 [details]
Ouput of KDE's crash manager
Comment 2 Sebastian Vahl 2008-10-31 19:10:20 EDT
Created attachment 322145 [details]
second try after removing feeds.opml
Comment 3 Sebastian Vahl 2008-10-31 19:10:49 EDT
Created attachment 322146 [details]
third try after removing feeds.opml
Comment 4 Sebastian Vahl 2008-10-31 19:42:18 EDT
Created attachment 322148 [details]
feeds.opml with some problematic feeds

I've done some tests and it seems that at least this feeds causes the crashes. So some new steps to reproduce this:

1. clean ~/.kde/share/config/akregatorrc and ~/.kde/share/apps/akregator/
2. start akregator
3. import this feeds.opml and update all feeds
4. close akregator completely (no icon in systray)
5. start akregator and see it's crashing
Comment 5 Sebastian Vahl 2008-10-31 19:43:44 EDT
Created attachment 322149 [details]
crash log created for the comment above
Comment 7 Rex Dieter 2008-11-11 09:56:56 EST
I think that made 4.1.3, but we'll have to wait-n-see.
Comment 8 Kevin Kofler 2008-11-11 11:58:44 EST
Can we please try a 4.1.2 build with these fixes included, for f10-final?
Comment 9 Jaroslav Reznik 2008-11-11 12:16:28 EST
At least, we should try. It's not a good image for us to release it buggy... Tomorrow I hope I can take a look.
Comment 10 Sebastian Vahl 2008-11-12 10:04:39 EST
confirmed to work with kdepim-4.1.2-5.fc10


scratch build: http://koji.fedoraproject.org/koji/taskinfo?taskID=928254
Comment 11 Bug Zapper 2008-11-25 23:35:34 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Note You need to log in before you can comment on or make changes to this bug.