Bug 469515 - kdm runs SCIM as root on desktop
kdm runs SCIM as root on desktop
Status: CLOSED DUPLICATE of bug 468814
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-01 15:56 EDT by Gerald Cox
Modified: 2008-11-04 19:50 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-04 19:50:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Control Panel with Dual SCIM Icons (13.14 KB, image/png)
2008-11-02 08:04 EST, Gerald Cox
no flags Details

  None (edit)
Description Gerald Cox 2008-11-01 15:56:56 EDT
Description of problem:
When KDE is started, dual SCIM Setup Icons appear on control panel.  


Version-Release number of selected component (if applicable):
scim-1.4.7-35.fc10.x86_64

How reproducible:
Normal system start


Steps to Reproduce:
1. Login into KDE
2.
3.
  
Actual results:

Dual SCIM Setup Icons appear on control panel.  You can manual exit one, but when you try to exit both, one keeps re-appearing.


Expected results:  
Only one SCIM Icon would appear on control panel.


Additional info:
Comment 1 Peng Huang 2008-11-01 21:26:55 EDT
Could you upload a snapshot for it? In F10, imsetting will show an icon in system tray. Are you sure those two icons is belong to SCIM?
Comment 2 Gerald Cox 2008-11-02 08:04:10 EST
Created attachment 322227 [details]
Control Panel with Dual SCIM Icons
Comment 3 Gerald Cox 2008-11-02 08:07:00 EST
When I right click on either icon, I receive SCIM Setup popup panel.  When I select exit on the icon to the left, the icon exits and doesn't reappear until the next login.  When I select exit on the icon to the right, the icon disappears and then reappears - I assuming the program is re-launching.
Comment 4 Peng Huang 2008-11-02 21:41:28 EST
Please provide processes information use below command

ps aux| grep scim
Comment 5 Jens Petersen 2008-11-03 18:56:49 EST
Gerald, do you normally run scim on your desktop?

If no, which locale are you using?
Comment 6 Gerald Cox 2008-11-03 19:09:29 EST
Here is the output of the ps aux | grep scim:

ps aux | grep scim
root      2213  0.0  0.1 193716  2944 ?        Ss   16:02   0:00 /usr/lib64/scim-1.0/scim-helper-manager
root      2214  0.0  0.2 206992  5160 ?        Ssl  16:02   0:00 /usr/lib64/scim-1.0/scim-panel-gtk --display :0.0 -c socket -d --no-stay
root      2216  0.0  0.0 117400   864 ?        Ss   16:02   0:00 /usr/lib64/scim-1.0/scim-launcher -d -c socket -e socket -f x11 --no-stay -d
gbcox     2604  0.0  2.3 306592 49004 ?        Ss   16:03   0:00 /usr/lib64/scim-1.0/scim-launcher -d -c simple -e all -f socket --no-stay -d
gbcox     2616  0.0  0.1 193732  2948 ?        Ss   16:03   0:00 /usr/lib64/scim-1.0/scim-helper-manager
gbcox     2617  0.0  0.2 204992  5244 ?        Ssl  16:03   0:00 /usr/lib64/scim-1.0/scim-panel-gtk --no-stay --display :0 -c socket -d
gbcox     2619  0.0  2.3 307072 47484 ?        S    16:03   0:00 scim-bridge
gbcox     2912  0.0  0.0  84756   776 pts/1    S+   16:06   0:00 grep scim

I haven't run SCIM - I am just doing the beta testing and it is something which is automatically started for me.  My locale is English - US.
Comment 7 Jens Petersen 2008-11-04 00:38:43 EST
Are you using kdm?
Comment 8 Jens Petersen 2008-11-04 03:55:48 EST
I think this is a duplicate of 468814.
Comment 9 Gerald Cox 2008-11-04 07:11:25 EST
Yes, I am using kdm.
Comment 10 Gerald Cox 2008-11-04 07:35:36 EST
Interesting.  I switched to gdm and the dual icon condition goes away.  Below is the output of the ps aux | grep scim command.  

ps aux | grep scim
gbcox     2808  0.0  0.1 193732  2948 ?        Ss   04:29   0:00 /usr/lib64/scim-1.0/scim-helper-manager
gbcox     2809  0.0  0.2 204960  5384 ?        Ssl  04:29   0:00 /usr/lib64/scim-1.0/scim-panel-gtk --display :0.0 -c socket -d --no-stay
gbcox     2811  0.0  0.0 117400   864 ?        Ss   04:29   0:00 /usr/lib64/scim-1.0/scim-launcher -d -c socket -e socket -f x11 --no-stay -d
gbcox     2821  0.0  2.3 306152 49008 ?        Ss   04:30   0:00 /usr/lib64/scim-1.0/scim-launcher -d -c simple -e all -f socket --no-stay -d
gbcox     2830  0.0  2.3 306156 47504 ?        S    04:30   0:00 scim-bridge
gbcox     3016  0.0  0.0  84756   780 pts/1    S+   04:31   0:00 grep scim
Comment 11 Gerald Cox 2008-11-04 07:38:49 EST
Here is what is in my /etc/sysconfig/i18n file:

LANG="en_US.UTF-8"
SYSFONT="latarcyrheb-sun16"
Comment 12 Jens Petersen 2008-11-04 19:48:34 EST
(In reply to comment #10)
> Interesting.  I switched to gdm and the dual icon condition goes away.

Yep so the root invocation of scim comes from kdm being a qt application (which you can then exit from since no root applications are running at that point) and the other invocation is by the qt apps in your kde desktop.
Comment 13 Jens Petersen 2008-11-04 19:50:10 EST

*** This bug has been marked as a duplicate of bug 468814 ***

Note You need to log in before you can comment on or make changes to this bug.