Bug 469518 - Taxipilot contains .la file
Taxipilot contains .la file
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: taxipilot (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
: EasyFix
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-01 16:42 EDT by Alexey Torkhov
Modified: 2008-11-14 14:28 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-14 10:05:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexey Torkhov 2008-11-01 16:42:00 EDT
Description of problem:
Taxipilot contains /usr/lib/libEXT_wavpo.la file.
It must be removed by packaging guidelines.

Also, for some reason taxipilot.i386 is included to x86_64 repo. (Probably because of this issue, probably not).

Version-Release number of selected component (if applicable):
taxipilot-0.9.2
Comment 1 Kevin Kofler 2008-11-01 20:03:43 EDT
If that library is loaded by the KDE 3 plugin loader, then the .la file cannot be removed (a known ages-old bug in the KDE 3 plugin loader).
Comment 2 Rex Dieter 2008-11-01 21:19:04 EDT
Kevin, that's what kdelibs3's kde-3.5-libtool-shlibext.patch is (supposedly) for (ie, out kdelibs3 is patched to try to avoid that).
Comment 3 Hans de Goede 2008-11-02 04:56:05 EST
(In reply to comment #1)
> If that library is loaded by the KDE 3 plugin loader, then the .la file cannot
> be removed (a known ages-old bug in the KDE 3 plugin loader).

Exactly, that is the reason why I've included them.

(In reply to comment #2)
> Kevin, that's what kdelibs3's kde-3.5-libtool-shlibext.patch is (supposedly)
> for (ie, out kdelibs3 is patched to try to avoid that).

IIRC I tested without the .la files and it did not work.
Comment 4 Hans de Goede 2008-11-14 10:05:16 EST
Ok, I've just tested another program with the same issue, and libltdl still needs .la files, even the libtool2 libltdl, so I'm closing this as notabug.
Comment 5 Kevin Kofler 2008-11-14 14:27:39 EST
Debian has patches for this stuff, the KDE patch pusling showed me looked fairly simple (and it's not the one we have now, which doesn't seem to work), they just replaced .la with .so in 2 places in kdelibs3.
Comment 6 Kevin Kofler 2008-11-14 14:28:00 EST
They probably also have patches for libtool.

Note You need to log in before you can comment on or make changes to this bug.