Bug 469525 - subversion - apr requirement version mismatch
subversion - apr requirement version mismatch
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: subversion (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-01 17:51 EDT by Jose Pedro Oliveira
Modified: 2009-03-09 10:10 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-09 10:10:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jose Pedro Oliveira 2008-11-01 17:51:24 EDT
Description of problem:
There is a version mismatch between the apr build requirement and apr the requirement:

  From the specfile:
  ---------
  ...
  BuildRequires: apr-devel >= 0.9.7, apr-util-devel >= 0.9.7
  ...
  Requires: apr >= 1.3.0
  ...
  ---------

Any particular reason for the version differences between the build requirement
and the requirement (0.9.7 vs 1.3.0) ?  

And why the 1.3.0 requirement?  At the end of the subversion 1.5 release notes
(http://subversion.tigris.org/svn_1.5_releasenotes.html) they only mention APR
1.x.

Note: already answered in #466674.
Comment 1 Bug Zapper 2008-11-25 23:37:30 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Jose Pedro Oliveira 2009-02-21 09:36:23 EST
The build requirements heave already been corrected.

CVS commits (rawhide and F10)
https://www.redhat.com/archives/fedora-extras-commits/2009-January/msg10187.html
https://www.redhat.com/archives/fedora-extras-commits/2009-January/msg10203.html
Comment 3 Jose Pedro Oliveira 2009-02-21 09:39:22 EST
Joe,

Shouldn't the devel subpackage also have versioned apr-devel/apr-util-devel requirements?


From the specfile:
-----------
%package devel
...
Requires: subversion = %{version}-%{release}, apr-devel, apr-util-devel
...
-----------
Comment 4 Joe Orton 2009-03-09 10:10:55 EDT
I can't see why that matters.  apr{,-util}-devel have lockstep requires on the apr{,-util} packages, so if the main package requires are correct, the -devel packages must also match.  

Thanks for reporting the original bug though - looks like I forgot to reference it when fixing the spec file.

Note You need to log in before you can comment on or make changes to this bug.