Bug 469543 - ATI driver selects a bad refresh rate
ATI driver selects a bad refresh rate
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-02 02:52 EST by Gordon Messmer
Modified: 2009-11-10 02:38 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-10 02:38:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf (803 bytes, text/plain)
2008-11-02 02:53 EST, Gordon Messmer
no flags Details
xorg log from session with xorg.conf present (225.96 KB, text/plain)
2008-11-02 02:55 EST, Gordon Messmer
no flags Details
xorg log from session with no xorg.conf (146.50 KB, text/plain)
2008-11-02 02:56 EST, Gordon Messmer
no flags Details

  None (edit)
Description Gordon Messmer 2008-11-02 02:52:01 EST
Description of problem:
Off and on during the beta for Fedora 10 (and more often than not), the ATI driver selects an odd refresh rate for the display.  It selects the correct optimal resolution for my monitor: 1280x1024, but the refresh rate is 64.8 kHz H and 59.9 Hz V.  Oddly, it only seems to happen if there is no xorg.conf.

When I use the attached xorg.conf, it selects the proper refresh rate: 80 kHz H / 75 Hz V.  I don't understand why, since the configuration file doesn't specify any modelines, it's just there to set my randr settings before login.

I'll also attach the logs from an X session with the configuration file and from a session without.

Version-Release number of selected component (if applicable):
xorg-x11-drv-ati-6.9.0-38.fc10.x86_64

How reproducible:
Always
Comment 1 Gordon Messmer 2008-11-02 02:53:07 EST
Created attachment 322205 [details]
xorg.conf
Comment 2 Gordon Messmer 2008-11-02 02:55:00 EST
Created attachment 322206 [details]
xorg log from session with xorg.conf present
Comment 3 Gordon Messmer 2008-11-02 02:56:44 EST
Created attachment 322207 [details]
xorg log from session with no xorg.conf
Comment 4 Bug Zapper 2008-11-25 23:38:21 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Tim Niemueller 2008-12-01 10:18:33 EST
I have the same problem with a couple of Dell Optiplex 755 Desktops with a Radeon HD 2400 XT (as reported by lspci). With the radeonhd driver it at least seems to select a reasonable refresh rate.

Note You need to log in before you can comment on or make changes to this bug.