Bug 469547 - Inconsistent font height rendering in Firefox 3.0.2
Inconsistent font height rendering in Firefox 3.0.2
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-02 06:01 EST by James
Modified: 2009-01-08 10:04 EST (History)
3 users (show)

See Also:
Fixed In Version: 3.0.5-1.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-08 10:04:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot showing inconsistent heights (371.80 KB, image/png)
2008-11-02 06:01 EST, James
no flags Details

  None (edit)
Description James 2008-11-02 06:01:12 EST
Created attachment 322211 [details]
Screenshot showing inconsistent heights

Description of problem:
Occasionally, after some browsing, the fonts on certain sites are rendered with inconsistent heights (see screenshot). Frequently the font concerned seems to be TrueType Arial, I've seen this bug show up when browsing Flickr and YouTube.

Version-Release number of selected component (if applicable):
firefox-3.0.2-1.fc9.x86_64
xorg-x11-drv-i810-2.3.2-2.fc9.x86_64
freetype-2.3.5-6.fc9.x86_64
freetype-2.3.5-6.fc9.i386

How reproducible:
Intermittent.

Steps to Reproduce:
1. Browse for a while.
2. Visit a site which provokes this (YouTube, Flickr)
  
Actual results:
Wonky glyph heights.

Expected results:
Consistent rendering.
Comment 1 Matěj Cepl 2008-11-03 06:48:07 EST
Are you able to reproduce this under the following conditions (each one of them or their combination)?
a) are you able to reproduce this with some other site than YouTube and Flickr -- these are one of the most Javascript heavy sites on the Internet, so it is difficult to find what problems could be caused by this?
b) using upstream binary from http://www.mozilla.com/products/download.html?product=firefox-3.0.3&os=linux&lang=en-US are able to reproduce this?
c) are you able to reproduce it with switched off plugins/extensions? I.e., when you run firefox -safe-mode do you reproduce this?
Comment 2 Andre Robatino 2008-11-03 07:39:20 EST
I have also seen this on rare occasions, and on sites other than the above two.  In fact, I think that once it happens, it happens on all sites visited during the browsing session.  But I have no idea what triggered it or how to reproduce it.  I'll keep an eye out and try to collect info if it happens again.
Comment 3 Matěj Cepl 2008-11-03 10:54:26 EST
OK, so let's put this into needinfo and let's see whether you manage to collect some more info about this.
Comment 4 Matěj Cepl 2008-11-29 11:01:10 EST
ping?
Comment 5 James 2008-11-29 11:36:59 EST
Sorry... I still see this, but I have no idea about what sequence of events provokes it.
Comment 6 Andre Robatino 2008-11-29 11:50:47 EST
I haven't seen it at all yet.  As I said, it's pretty rare.  In addition, I'm running F10 now.
Comment 7 James 2008-12-29 09:13:08 EST
I've not seen this in a while on firefox-3.0.5-1.fc10.x86_64. Anyone else want to chime in before I close it CURRENTRELEASE?
Comment 8 Matěj Cepl 2008-12-29 15:52:21 EST
Let's put NEEDINFO here.
Comment 9 James 2009-01-08 10:04:33 EST
I think it's probably safe to conclude for now that this has been fixed, closing.

Note You need to log in before you can comment on or make changes to this bug.