Bug 469577 - xorg is slow and unresponsive
xorg is slow and unresponsive
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
10
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-02 15:33 EST by Espen Stefansen
Modified: 2009-06-17 06:20 EDT (History)
12 users (show)

See Also:
Fixed In Version: somewhere
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-17 06:20:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.0.log (95.63 KB, text/plain)
2008-11-02 15:35 EST, Espen Stefansen
no flags Details
Xorg.0.log, not using a xorg.conf file. (65.23 KB, text/plain)
2008-12-06 02:54 EST, Ira Malinich
no flags Details
My xorg configuration (1.61 KB, text/plain)
2008-12-21 12:40 EST, Stan Trzmiel
no flags Details

  None (edit)
Description Espen Stefansen 2008-11-02 15:33:26 EST
Description of problem:
After i updated my machine with xorg packages the last 4-5 days, xorg has gotten slow and unresponsive. Everything seems sluggish. Xorg usually takes minimum about 20% CPU and maxes out when opening/closing, maximizing/minimizing programs or push programs to the foreground. If i play music as well, the music stop at times because xorg takes 100% CPU. For instance, if i take a program to the foreground it takes about 4 seconds to show, the same time to minimize. Or just change tabs in Opera, takes seconds. Much slower than a week ago. Xorg is actually using lots of cpu for the slightest thing.

If the screensaver is on, it always uses 100% on one CPU.

Version-Release number of selected component (if applicable):
xorg-x11-server-common-1.5.2-10.fc10.i386
xorg-x11-server-Xorg-1.5.2-10.fc10.i386
xorg-x11-drv-ati-6.9.0-41.fc10.i386

How reproducible:
All the time

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Espen Stefansen 2008-11-02 15:35:44 EST
Created attachment 322236 [details]
xorg.0.log
Comment 2 Bug Zapper 2008-11-25 23:39:31 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Ira Malinich 2008-12-06 02:50:47 EST
I'm seeing the same behaviour, but only when Compiz is running.  I'm using a Fedora 9 preupgraded to Fedora 10.  Since the upgrade the window animations that were previously very smooth now only show a few frames of animation, or even just a delay before the last two or three frames.  Although some such as window wobble seems to have much less visible decrease in performance.
Scrolling in Firefox is the worst example I've seen so far.  It takes between four and seven seconds to scroll after I press <PgDn>.

In all cases Xorg can be seen using anywhere from 30-95% of CPU in top.  In fact I never see Xorg drop below 24% CPU while Compiz is running.

My smolt profile:  http://www.smolts.org/client/show/pub_890cf4ed-b3bf-4a01-a234-329d1986ea3c

Also, I'll attach my xorg.0.log.

Is this the same bug?  Should I be opening a bug under Compiz?
Comment 4 Ira Malinich 2008-12-06 02:54:44 EST
Created attachment 325973 [details]
Xorg.0.log, not using a xorg.conf file.
Comment 5 Stan Trzmiel 2008-12-21 12:39:40 EST
Same things here. 


Software
Fedora 10 32bit
kernel-2.6.27.7-134.fc10.i686
xorg-x11-drv-ati-6.9.0-62.fc10.i386
mesa-dri-drivers-7.2-0.15.fc10.i386
xorg-x11-server-Xorg-1.5.3-6.fc10.i386

DRI enabled

Hardware:
PIV 3.0 mHT Prescot
i865 chipset
Radeon 9550 128MB
1GB RAM dual-channel



In Fedora10 the performance is reduced compared to F9 and earlier.
Glxgears push ~520 fps (desktop 1024x768 24), KDE envirnoment works good good enough with composite off. Effects are bit slow, not a slideshow, but still a bit slow.
Glxgears under F9 gets +1500 fps with effects enabled; +1950 without.

I've also tried Rawhide install (KDE 4.1.85, kernel 2.28) and things are even worse. Glxgears runs @ 160-190 fps, xorg is unresponsive even without effects.
With driver changed to vesa KDE works smooth.

I've attached my xorg.conf (the same for F9 and 10)
Comment 6 Stan Trzmiel 2008-12-21 12:40:34 EST
Created attachment 327585 [details]
My xorg configuration
Comment 7 Todd Newell 2008-12-22 15:28:10 EST
I am experiencing similar problems here.  When no changes are happening on the screen (other than "top" running in a terminal window), Xorg shows a pretty much constant use of 10.3% of the CPU.  Occasionally the usage will drop to something like 4.3%, but then returns back to 10.3%.  When there is screen activity, such as scrolling the Firefox browser window, or even just moving the mouse arrow around, the CPU usage for Xorg shoots upward.  In the case of the scrolling browser window, CPU usage jumps up above 80%.

I have:
Fedora 10 (32 bit)
kernel-PAE-2.6.27.7-134.fc10.i686
xorg-x11-server-Xorg-1.5.3-6.fc10.i386
xorg-x11-drv-ati-6.9.0-62.fc10.i386

Please let me know what other pertinent information I can provide.  Thanks.
Comment 8 Garrett Holmstrom 2009-01-09 18:29:59 EST
I'm getting this too, on a brand new, completely-updated install.  I can get the Xorg process up to 95% CPU usage just by moving a terminal window around.  Xorg idles at around 1.3%.

kernel-PAE-2.6.27.9-159.fc10.i686
xorg-x11-server-Xorg-1.5.3-6.fc10.i386
xorg-x11-drv-nv-2.1.12-6.fc10.i386
(no Xorg.conf)

Intel Core 2 Duo 2.2 GHz
Nvidia GeForce 8600M
Comment 9 Stan Trzmiel 2009-02-08 13:04:46 EST
The problem still persist.

Kernel-2.6.27.12-170.2.5.fc10
libdrm-2.4.0-0.21.fc10.i386
xorg-x11-drv-ati-6.10.0-1.fc10.i386
xorg-x11-server-Xorg-1.5.3-11.fc10.i386
mesa-libGL-7.2-0.15.fc10.i386
mesa-dri-drivers-7.2-0.15.fc10.i386

Partial solution is disable KMS (nomodeset kernel switch) 
But still it's much slower than it was under Fedora 9, and it forces   "EnablePageFlip" "off" option in xorg.conf.

I guess we'll have to wait for F11 and mature gfx memory management.
Comment 10 Garrett Holmstrom 2009-02-08 22:31:32 EST
If anyone is interested, I have the same problem with RHEL 5.3 on the same machine that had this problem occur with Fedora 10.
Comment 11 jghobrial 2009-04-15 17:01:54 EDT
Seeing it as well. Logging off and on seems to clear X.

pmap -x $(pidof Xorg) | grep -vE "(\-\-\-\-\-\-|Address|total|Xorg)" | sort -k 2 -n

Didn't catch it last time, but I'll run the above to see if something can be deduced.

RHEL 5u3.
Comment 12 Shadab I. Wadiwala 2009-05-12 14:58:25 EDT
I did a good amount of research for the entire day on Sunday May 10, 2009

Finally on 12th May I referred the following link.

http://www.bramschoenmakers.nl/en/node/549  ( Fixing Plasma performance with
the open source Radeon driver ) 

I implemented the solution provided in the above link on my IBM Thinkpad R40,
with ATI Mobility Radeon R40 ( R100 based chip )

i am running  Fedora 10

Earlier I used to have a Xorg CPU percentage unusually high 
Mostly above 90 % always

I had a slow response especially using Firefox tabbing ( a delay of about 2
seconds )

Also, the response was slow using Dolphin file manager and doing all such tasks

But now after implementing the solution provided in
http://www.bramschoenmakers.nl/en/node/549

THE CPU percentage for Xorg process has considerably reduced.

I can use Firefox tabs with ease ( almost immediate response to mouse click )

Also when I click any icon in Dolphin, it opens up almost immediately

I hope my inputs will help in speedy resolution of this bug

I am thankful to Bram Schoenmakers for his valuable solution at
http://www.bramschoenmakers.nl/en/node/549  

Use the following two options in Xorg.conf  under Device section

Use the following two options in Xorg.conf  under Device section

Option "AccelMethod" "EXA"
Option "AccelDFS" "true" 


Thanks & Regards,
Shadab
+919373960745
====================================================
Comment 13 Charlie Brady 2009-06-16 09:58:11 EDT
> Use the following two options in Xorg.conf  under Device section
>
> Option "AccelMethod" "EXA"
> Option "AccelDFS" "true" 

Those haven't helped for me, with ATI Technologies Inc RV370 [Radeon X300SE], and AMD X86_64.
Comment 14 Charlie Brady 2009-06-16 10:00:19 EDT
Performance seems to be bearable using the vesa driver.
Comment 15 Espen Stefansen 2009-06-16 10:13:57 EDT
As the original reporter I can say that this has been fixed for me a long time ago.

Note You need to log in before you can comment on or make changes to this bug.