Bug 46958 - Installer doesn't recognize CDROM
Installer doesn't recognize CDROM
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
7.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-02 10:26 EDT by Need Real Name
Modified: 2007-04-18 12:34 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-03 15:12:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-07-02 10:26:20 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)

Description of problem:
I have downloaded the RH Lin. 7.1 ISOs from the site, extracted them and 
burned to CD (stupid Nero Burning tool), but when the installation tool 
boots (and it can boot from the CD) it enters the text mode and stops with 
the message:
"I could not find a Red Hat Linux CDROM in any of your CDROM drives. 
Please insert the Red Hat CD and press "OK" to retry"
If I press OK, the same message reapears. In the console found at Alt-F3 
message "* trying to mount device hdc" is displayed.
What is even more curious is that if I make the ISOs back from the disks 
and put them on the HD, the installer doesn't complain. Because I have to 
do another installation it would be impossible to use this method again.
I have already ordered te official Red Hat package, but because of the 
time frame I am in, I need this ASAP

How reproducible:
Always

Steps to Reproduce:
1.Insert CD and boot
2.Choose the language and keyboard
3.Choose to install from CDROM
4. System hangs
	

Actual Results:  I could not find a Red Hat Linux CDROM in any of your 
CDROM drives. Please insert the Red Hat CD and press "OK" to retry

Expected Results:  Continuation of installation

Additional info:

I was quite able to install Red Hat Linux 7.0 using the same procedure 
that I have described.
Comment 1 Brent Fox 2001-07-02 10:49:44 EDT
You need to make a boot disk with the boot.img file in the /images directory of
the cdrom.  Boot off that floppy and then select CDROM as the installation
media.  Please reopen this bug if this doesn't fix the problem.
Comment 2 Need Real Name 2001-07-02 10:56:36 EDT
No, the problem is not in the booting image as the system boots correctly, but 
in the access to the CDROM. I have tried both ways - booting from diskette, and 
booting from CDROM - it boots, but doesn't load from CDROM.
Comment 3 Brent Fox 2001-07-02 14:44:16 EDT
Are you sure that there's nothing wrong with the cd?  7.1 used a 2.88MB boot
image, and some motherboards were not able to see the second stage installer on
the cd if you booted off the cd.  Booting with a floppy avoids this problem, but
if you still can't see the cdrom, I don't know what the problem is.
Comment 4 Need Real Name 2001-07-02 15:51:20 EDT
Well, I think that everything is OK with the CD.. You can read from it in 7.0, 
you can read from it in 7.1 once installed, you can create ISO from it... One 
idea: is there some kind of FS support for ISO (like Joliet extension, or 
something like that) that is not built into the kernel on the diskette image, 
but is built into the standard kernel? I am asking this because I wasn't able 
to burn the CD straight from the ISO (Nero Burner doesn't have this option), 
but had to extract the ISOs, and then burn them as files on the CDROM. I have 
enabled Joliet extension to allow for long filenames.
Apart from this, I have no other idea... Perhaps some sort of copyright 
protection you have built into CD ISO image?
Comment 5 Brent Fox 2001-07-03 15:12:01 EDT
No no no, there is no copyright protection built in to the ISO images.  The cd's
are not going to work if you extract the files and simply burn them to the cd. 
I am surprised that the cd even boots at all.  You need to find a different cd
burning application that will let you burn an iso to the cdrom, and then things
will work.  

This is not an installer bug...the cd's were burned incorrectly.

Note You need to log in before you can comment on or make changes to this bug.