Bug 469584 - Slow framerate Intel x3100 (GM965/GL960)
Slow framerate Intel x3100 (GM965/GL960)
Status: CLOSED DUPLICATE of bug 444328
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
10
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-02 16:48 EST by Jaroslav Barton
Modified: 2009-10-22 09:01 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-06 03:57:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
X org log (63.86 KB, text/plain)
2008-11-02 16:48 EST, Jaroslav Barton
no flags Details
glxinfo (7.04 KB, text/plain)
2008-11-02 16:53 EST, Jaroslav Barton
no flags Details

  None (edit)
Description Jaroslav Barton 2008-11-02 16:48:58 EST
Created attachment 322239 [details]
X org log

Description of problem:
Slow framerate with Intel x3100 graphics on Thinkpad R61 (14inch).


Version-Release number of selected component (if applicable):
xorg-x11-drv-i810-2.5.0-1.fc10.x86_64


Steps to Reproduce:
- disable all desktop effects
- run glxgears
  
Actual results:
847 frames in 5.0 seconds = 169.308 FPS

Expected results:

~4500 frames in 5.0 seconds = ~900 FPS
Comment 1 Jaroslav Barton 2008-11-02 16:53:00 EST
Created attachment 322240 [details]
glxinfo
Comment 2 Jaroslav Barton 2008-11-02 16:54:00 EST
Linux loki.djaara.net 2.6.27.4-68.fc10.x86_64 #1 SMP Thu Oct 30 00:25:13 EDT 2008 x86_64 x86_64 x86_64 GNU/Linux
Comment 3 Jaroslav Barton 2008-11-03 10:26:56 EST
On Ubuntu runninng xserver-xorg-video-intel-2.2.1-1ubuntu13.7:

5602 frames in 5.0 seconds = 1120.372 FPS
5719 frames in 5.0 seconds = 1143.705 FPS
5699 frames in 5.0 seconds = 1139.686 FPS

(Linux loki 2.6.24-19-generic #1 SMP Wed Aug 20 17:53:40 UTC 2008 x86_64 GNU/Linux)
Comment 4 Jaroslav Barton 2008-11-20 10:25:57 EST
With xorg-x11-drv-i810-2.5.0-3.fc10.x86_64 is framerate in glxgears acceptable:

$ glxgears
5251 frames in 5.0 seconds = 1050.063 FPS
5511 frames in 5.0 seconds = 1102.183 FPS
5524 frames in 5.0 seconds = 1104.743 FPS
5395 frames in 5.0 seconds = 1078.894 FPS
Comment 5 Bug Zapper 2008-11-25 23:39:51 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 James 2008-12-01 07:01:34 EST
(In reply to comment #4)
> With xorg-x11-drv-i810-2.5.0-3.fc10.x86_64 is framerate in glxgears acceptable:
> 
> $ glxgears
> 5251 frames in 5.0 seconds = 1050.063 FPS
> 5511 frames in 5.0 seconds = 1102.183 FPS
> 5524 frames in 5.0 seconds = 1104.743 FPS
> 5395 frames in 5.0 seconds = 1078.894 FPS

Hmm. I'm only seeing roughly half that:

[james@rhapsody ~]$ glxgears 
2596 frames in 5.0 seconds = 519.091 FPS
2604 frames in 5.0 seconds = 520.707 FPS
Comment 7 Vedran Miletić 2009-09-06 03:57:26 EDT

*** This bug has been marked as a duplicate of bug 444328 ***

Note You need to log in before you can comment on or make changes to this bug.