Bug 469591 - Sound skipping due to alsa sink underruns
Sound skipping due to alsa sink underruns
Status: CLOSED DUPLICATE of bug 462026
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2008-11-02 18:18 EST by Dennis Jacobfeuerborn
Modified: 2008-11-09 16:36 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-11-09 16:36:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Ouput of "pulseaudio -vvvv" (21.95 KB, text/plain)
2008-11-02 18:18 EST, Dennis Jacobfeuerborn
no flags Details

  None (edit)
Description Dennis Jacobfeuerborn 2008-11-02 18:18:02 EST
Created attachment 322247 [details]
Ouput of "pulseaudio -vvvv"

I get sound skipping or "hickup" issues when playing audio through pulseaudio. Playing using alsa directly works fine. Attached is the output of "pulseaudio -vvvv". The skipping always occurs when a line "I: module-alsa-sink.c: Underrun!" appears.
Comment 1 Muayyad Alsadi 2008-11-08 06:10:19 EST
I confirm having this problem

but I'm not sure if it's specific to pulse or alsa because I hear the skips in both alsasink and pulsesink (less frequent)

gst-launch filesrc location=test.ogg ! decodebin ! queue ! alsasink
gst-launch filesrc location=test.ogg ! decodebin ! queue ! pulsesink

but oss4sink or osssink does not work at all

gst-launch filesrc location=test.ogg ! decodebin ! queue ! osssink
Setting pipeline to PAUSED ...
Pipeline is PREROLLING ...
ERROR: from element /GstPipeline:pipeline0/GstFileSrc:filesrc0: Internal data flow error.
Additional debug info:
gstbasesrc.c(2234): gst_base_src_loop (): /GstPipeline:pipeline0/GstFileSrc:filesrc0:
streaming task paused, reason not-linked (-1)
ERROR: pipeline doesn't want to preroll.
Setting pipeline to NULL ...
FREEING pipeline ...
Caught SIGSEGV accessing address 0x40
Comment 2 Kevin Kofler 2008-11-09 16:15:09 EST
Chances are your use of the GStreamer alsasink:
> gst-launch filesrc location=test.ogg ! decodebin ! queue ! alsasink
also uses PulseAudio (through the PulseAudio ALSA plugin).
Comment 3 Charles R. Anderson 2008-11-09 16:36:14 EST

*** This bug has been marked as a duplicate of bug 462026 ***

Note You need to log in before you can comment on or make changes to this bug.