Bug 469606 - galeon says "myportal is not a registered protocol"
galeon says "myportal is not a registered protocol"
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: galeon (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Denis Leroy
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-03 00:15 EST by Michal Jaegermann
Modified: 2009-10-05 16:44 EDT (History)
3 users (show)

See Also:
Fixed In Version: 2.0.7-15.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-23 03:40:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2008-11-03 00:15:56 EST
Description of problem:

When starting galeon in a default configuration then instead of an expected "splash screen" with a list of current bookmarks, like galeon used to show an alert "myportal is not a registered protocol" shows up and a screen is blank.
That happens at least for the current rawhide.

How reproducible:
always
Comment 1 Michal Jaegermann 2008-11-03 11:36:54 EST
In 'configure' script for galeon there is the following:

 Note that Galeon has a runtime dependency on the 'cookie' and 'permission'
 mozilla extensions. These are not built as part of the default xulrunner
 build, and must be added explicitly at xulrunner configure-time.

This is printed on a screen when configuring galeon to build with xulrunner or libxul-embedding or libxul-embedding-unstable. OTOH about:buildconfig in galeon appears to show a build configuration for an underlying xulrunner (galeon-2.0.7-2.fc10 and xulrunner-1.9.0.2-5.fc10).  The only extensions mentioned there are default and python/xpcom.  Maybe that is it what is causing the problem?

In any case it looks like that a used xulrunner configuration is not good enough for galeon needs.  The quoted text says "must".  It has also some followup text which warns agains using  'typeaheadfind' and 'wallet' extensions but those are indeed absent - at least for the moment.
Comment 2 Bug Zapper 2008-11-25 23:40:17 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Denis Leroy 2009-09-23 03:40:50 EDT
Fixed in next release.
Comment 4 Fedora Update System 2009-09-23 03:56:11 EDT
galeon-2.0.7-15.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/galeon-2.0.7-15.fc11
Comment 5 Fedora Update System 2009-10-03 15:12:55 EDT
galeon-2.0.7-15.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Mark Harig 2009-10-05 11:39:16 EDT
$ rpm -q galeon
galeon-2.0.7-15.fc11.x86_64

$ rpm -V galeon && echo $?
0

$ cat /etc/fedora-release
Fedora release 11 (Leonidas)

The following steps still lead to the error message "myportal is not a registered protocol" being displayed:

1. Click on 'Go' in galeon's main menu.

2. Click on 'My Portal' in the Go sub-menu.

An error message window with a lightbulb icon and the text "myportal is not a registered protocol" is displayed.

Should this be reported as a separate error in galeon in the Fedora 11?
Comment 7 Denis Leroy 2009-10-05 12:30:36 EDT
A patch would be preferred... we just need to remove it from the menu...
Comment 8 Mark Harig 2009-10-05 16:44:49 EDT
(In reply to comment #7)
> A patch would be preferred... we just need to remove it from the menu...  

Is 'myportal' no longer a feature of galeon?  Here is some of the documentation describing it in the galeon User's Guide.  At present, these features do work as described in the manual.

"'My Portal' creates a portal style view of your bookmarks in a
web page. It makes a good choice for your homepage, since it
provides a rapid way of jumping to a large number of bookmarks.
You can visit 'My Portal' at any time by opening the URL
about:myportal, or you can set it as your
homepage, as described in Section 3.1 ― General."

and

Home Page

"When Galeon first starts up, it will automatically load the
page specified here. Type an address into the entry bar or,
if you are currently viewing a page you would like to set
as your permanent home page, click the Set to Current button.
If you want the 'My Portal' page your home page by (sic),
type in myportal:."

Note You need to log in before you can comment on or make changes to this bug.