Bug 469611 - endless loop in mkinitrd
endless loop in mkinitrd
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On: 465542
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-03 01:21 EST by Alexandre Oliva
Modified: 2008-12-04 23:02 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-04 23:02:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch that avoids searches in the wrong dirs and mismatched qpops, and thus the endless loop (846 bytes, patch)
2008-11-03 01:21 EST, Alexandre Oliva
no flags Details | Diff

  None (edit)
Description Alexandre Oliva 2008-11-03 01:21:13 EST
Created attachment 322261 [details]
Patch that avoids searches in the wrong dirs and mismatched qpops, and thus the endless loop

Description of problem:
When qpushd fails because the named directory does not exist, we go happily ahead searching for stuff in the wrong directory, and then qpop what the caller had pushed.  Enough of these pops and we end up back in /tmp, and entering an endless loop because $PWD will never end up matching /sys, no matter how many times we cd .. in findstoragedriverinsys.

I ran into this after a couple of USB bus resets left me with two failed slaves for the RAID device holding the root filesystem (in an encrypted physical volume), later re-added as the disk came back up:

md3 : active raid1 sde3[1] sdd3[3](F) sda3[0] sdb3[2] sdc3[4](F)
      77650112 blocks [3/3] [UUU]
      bitmap: 0/149 pages [0KB], 256KB chunk

It didn't matter that bug 465542 wasn't fixed yet, it still tried to descend into the components of md3, and failed at that.

The attached patch, along with the patch for bug 465542 (strictly speaking, probably not needed to fix the bug, but what the heck :-) fixes it.


Version-Release number of selected component (if applicable):
mkinitrd-6.0.69-1
Comment 1 Peter Jones 2008-11-03 17:31:07 EST
Should be fixed in 6.0.70-1 .
Comment 2 Bug Zapper 2008-11-25 23:40:24 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Alexandre Oliva 2008-12-04 23:02:17 EST
Confirmed fixed in F-10 GOLD, thanks.

Note You need to log in before you can comment on or make changes to this bug.