Bug 469612 - Net::SSH::Perl is at 1.33
Net::SSH::Perl is at 1.33
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: perl-Net-SSH-Perl (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Howarth
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-03 01:24 EST by Chris Weyl
Modified: 2008-11-26 21:09 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-26 21:09:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Weyl 2008-11-03 01:24:15 EST
Net::SSH::Perl is at 1.33; significantly newer than the 1.30 release.  Can we update to 1.33 in F-9/devel?

Note the *UNAUTHORIZED* flag by 1.33 in CPAN appears to be the oversight of marking one of the components as co-maintained by the current release author.  I've filed a bug at rt:

http://rt.cpan.org/Public/Bug/Display.html?id=40617
Comment 1 Paul Howarth 2008-11-03 09:01:30 EST
I've done a build for devel but Bodhi won't let me submit an update for it at the moment, claiming that "perl-Net-SSH-Perl-1.33-1.fc10 not tagged as an update candidate".

http://koji.fedoraproject.org/koji/taskinfo?taskID=915521

How did you know about this update? The upstream URL I use (http://search.cpan.org/dist/Net-SSH-Perl/) has no mention of it, hence my updates-checking script didn't alert me to it.

I'm looking at packaging Math::BigInt::{GMP,Pari} as it seems that Math::BigInt works differently with specialized maths libraries than it did when I originally put this package together. I may wait until they're ready before pushing updates of this one.
Comment 2 Chris Weyl 2008-11-03 12:42:38 EST
If a release is uploaded to PAUSE containing modules whose namespace the author doesn't own (either through ownership, co-maintainer rights, or mine-because-I-asked-for-it-first)), PAUSE will accept the upload and it will appear in the CPAN, but it won't be indexed. This is a perfectly normal sanity check that helps to keep people from accidentally stepping on each other...  I only found this release as I was poking around, trying to find something that would talk to ssh-agent for me :)

Normally I'd stay away from anything flagged "unauthorized", as it's a good sign something needs to be worked out between the maintainers, but in this case it appears to be a simple glitch getting everything aligned properly.
Comment 3 Paul Howarth 2008-11-04 06:19:36 EST
(In reply to comment #1)
> I'm looking at packaging Math::BigInt::{GMP,Pari} as it seems that Math::BigInt
> works differently with specialized maths libraries than it did when I
> originally put this package together. I may wait until they're ready before
> pushing updates of this one.

Looks like we only need Math::BigInt::GMP for SSH2 support. Once this package is in, I'll update Crypt::DH and Crypt::DSA to pull it in and then the "failed to find math libraries" warnings will go away.

https://bugzilla.redhat.com/show_bug.cgi?id=469833

The Net::SSH::Perl package doesn't need to change to make this happen so I'll have another try at pushing an update for this.
Comment 4 Fedora Update System 2008-11-04 06:30:29 EST
perl-Net-SSH-Perl-1.33-2.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/perl-Net-SSH-Perl-1.33-2.fc10
Comment 5 Fedora Update System 2008-11-04 06:51:41 EST
perl-Net-SSH-Perl-1.33-2.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/perl-Net-SSH-Perl-1.33-2.fc9
Comment 6 Fedora Update System 2008-11-06 21:51:32 EST
perl-Net-SSH-Perl-1.33-2.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update perl-Net-SSH-Perl'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-9417
Comment 7 Fedora Update System 2008-11-19 09:46:22 EST
perl-Net-SSH-Perl-1.33-2.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2008-11-22 11:53:11 EST
perl-Net-SSH-Perl-1.33-2.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update perl-Net-SSH-Perl'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/f10/FEDORA-2008-10000
Comment 9 Bug Zapper 2008-11-25 23:40:30 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 10 Fedora Update System 2008-11-26 21:09:21 EST
perl-Net-SSH-Perl-1.33-2.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.