Bug 469664 - Quitting dx leaves a zombie dxexec process behind causing 100% CPU load
Summary: Quitting dx leaves a zombie dxexec process behind causing 100% CPU load
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: dx
Version: 10
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dominik 'Rathann' Mierzejewski
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-11-03 10:59 UTC by Joachim Frieben
Modified: 2013-01-23 01:37 UTC (History)
2 users (show)

Fixed In Version: dx-4.4.4-8.fc10
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-02-05 02:20:07 UTC


Attachments (Terms of Use)

Description Joachim Frieben 2008-11-03 10:59:42 UTC
Description of problem:
After trying some sample file with dx and quitting the application, the "top" utility shows a high CPU load process dxexec as a remains of dx.

Version-Release number of selected component (if applicable):
dx-4.4.4-7.fc10.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. Launch dx.
2. Execute some sample provided by xd-smaples.
3. Quit dx.
  
Actual results:
The current process list reveals that there is some zombie process dxexec left over from dx causing 100% CPU load.

Expected results:
No dexec process.

Additional info:
This has also been observed independently on some i386 system.

Comment 1 Bug Zapper 2008-11-26 04:40:44 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 2 Dominik 'Rathann' Mierzejewski 2008-12-01 22:02:52 UTC
Looks like it's already been reported upstream last year: http://www.opendx.org/bugs/view.php?id=236 .

Comment 3 Joachim Frieben 2009-01-21 19:38:46 UTC
A patch has been suggested in this thread of the OpenDX forum:

  http://www.opendx.org/cgi-bin/forum/YaBB.pl?num=1176042404

Comment 4 Dominik 'Rathann' Mierzejewski 2009-01-28 20:24:40 UTC
Please don't close the bug report before the fixed packages have been pushed to updates.

Comment 5 Fedora Update System 2009-01-29 23:03:27 UTC
dx-4.4.4-8.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update dx'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-1099

Comment 6 Fedora Update System 2009-01-29 23:11:48 UTC
dx-4.4.4-7.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing-newkey update dx'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2009-1185

Comment 7 Fedora Update System 2009-02-05 02:20:04 UTC
dx-4.4.4-8.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2009-02-05 02:22:18 UTC
dx-4.4.4-7.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.