Bug 469708 - dependency error during sw02 -> sw03 package upgrade
dependency error during sw02 -> sw03 package upgrade
Status: CLOSED CURRENTRELEASE
Product: Spacewalk
Classification: Community
Component: Installation (Show other bugs)
0.3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Miroslav Suchý
Milan Zazrivec
:
Depends On:
Blocks: space03
  Show dependency treegraph
 
Reported: 2008-11-03 11:25 EST by Milan Zazrivec
Modified: 2012-03-06 03:56 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-27 09:10:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milan Zazrivec 2008-11-03 11:25:01 EST
Description of problem:
* installed spacewalk 0.2 / i386
* yum set up to use spacewalk 0.3 QA repo
* yum upgrade fails with following error:

# yum upgrade
...
--> Finished Dependency Resolution
Error: Missing Dependency: NPusers is needed by package np-config

This is on Spacewalk 0.2 installation:
# rpm -q np-config NPusers
np-config-2.110.4-1.el5.sw
NPusers-1.17.12-1.el5.sw

This is what latest nocpulse-common from 0.3 QA repo says:
# rpm -qp --obsoletes nocpulse-common-2.0.15-1.el5.sw.noarch.rpm 
NPusers <= 1.17.50-1
np-config <= 2.110.3-7

Version-Release number of selected component (if applicable):
nocpulse-common-2.0.15-1
Comment 1 Miroslav Suchý 2008-11-04 04:15:42 EST
Hmm, I can not reproduce it. Although the bug seems to be obvious.
Commited ba3484dca8e312ad119f693472d1e910249db176 (0.3)
and 012b6b8161f1c3fc01b9a23a866cb47d5a4df2da (master).
Built and tagged nocpulse-common-2.0.16-1
Comment 2 Milan Zazrivec 2008-11-12 06:41:52 EST
Verified upgrade with nocpulse-common-2.0.16-1

Note You need to log in before you can comment on or make changes to this bug.