Bug 469722 - very low volume after resume from suspend on acer netbook (snd-hda-intel)
very low volume after resume from suspend on acer netbook (snd-hda-intel)
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jaroslav Kysela
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-03 13:56 EST by Jason Farrell
Modified: 2009-02-05 05:47 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-05 05:47:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason Farrell 2008-11-03 13:56:18 EST
Description of problem:
After resuming from suspend, the playback volume is limited to a barely audible level, even after maxing all available mixers. This is a regression from F9.

Version-Release number of selected component (if applicable):
kernel-2.6.27.4-68.fc10.i686

How reproducible:
f10snap3 liveinstall on an Acer Aspire One netbook.


Additional info:
There is a known workaround for this problem: to pass a "model=acer" option to the kmod, since 'auto' is not working. i.e.:

  echo 'options snd-hda-intel model=auto' > /etc/modprobe.d/snd-hda-intel.acer.conf

smolt profile:  http://www.smolts.org/client/show/pub_bbb797ed-9156-4880-ac9f-7f16013a9b79
Comment 1 Jason Farrell 2008-11-11 15:44:49 EST
I should add that forcing "model=acer" isn't an ideal workaround either, since while it does fix the low volume issue after suspend/resume, a new problem arises: the external speakers don't mute when headphones are plugged in.
Comment 2 Bug Zapper 2008-11-25 23:41:57 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Jason Farrell 2008-11-28 13:29:22 EST
working workaround is to use model=toshiba instead. you lose the internal mic, but at least the sound volume is normal after suspend/resume. see: https://help.ubuntu.com/community/AspireOne#AUDIO:
Comment 4 Jaroslav Kysela 2009-02-04 06:15:12 EST
Could you attach output from 'alsa-info.sh --no-upload' before suspend (normal volume levels) and after suspend (low volume levels)?

Please, remove 'model=' changes from configuration files to provide valid information.
Comment 5 Jason Farrell 2009-02-05 05:47:48 EST
recent updates seem to have fixed this problem, as i can no longer reproduce. the model=toshiba hack is no longer necessary; sound remains at previous volume after resume from suspend. great!

Note You need to log in before you can comment on or make changes to this bug.