Bug 469723 - Cannot mount floppy disk
Cannot mount floppy disk
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kdebase (Show other bugs)
5.4
All Linux
medium Severity medium
: rc
: ---
Assigned To: Ngo Than
desktop-bugs@redhat.com
:
Depends On:
Blocks: 5.4/TechnicalNotes
  Show dependency treegraph
 
Reported: 2008-11-03 13:58 EST by ritz
Modified: 2010-10-23 01:32 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
version 0.5 of the Hardware Abstraction Layer (HAL) creates child device objects only when a file system is mounted. In cases where a storage device cannot be polled (for example, a floppy drive or IDE Zip drive), HAL adds mount methods to the device itself rather than the volume. Previously, this meant that when used in conjunction with HAL 0.5, KDE 3 would not allow users to mount filesystems on devices which the HAL could not poll. KDE now includes a modified HAL back end that allows users to mount and unmount volumes through the storage devices detected by the HAL.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 05:37:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch based on upstream code (9.33 KB, patch)
2008-11-03 14:01 EST, ritz
no flags Details | Diff
lshal o/p (7.55 KB, text/plain)
2008-12-08 07:16 EST, ritz
no flags Details

  None (edit)
Description ritz 2008-11-03 13:58:51 EST
Description of problem:
After hotplugging USB-FDD the Device will be shown, but is not accssesible. No Mount possible.

Version-Release number of selected component (if applicable):
kdebase-3.5.4-18.el5

How reproducible:
always

Steps to Reproduce:
1. Try too click and mount floppy disk
  
Actual results:
Error Message in a popup window:
Error - Konqueror
Method ´Mount´ with signature ´ssas´ on interface ´org.freedesktop.Hal.Device.Volume´ doesn´t exist.

Expected results:
Should mount floppy disk

Additional info:
patch attached.
Comment 1 ritz 2008-11-03 14:01:10 EST
Created attachment 322352 [details]
patch based on upstream code

http://bugs.kde.org/120619
Fix mounting of floppies, patch by Wang Baisheng, great thanks. Tested by me & other users. Approved by Kevin.

http://websvn.kde.org/branches/KDE/3.5/kdebase/kioslave/media/mediamanager/halbackend.cpp?r1=613652&r2=615516&diff_format=u
http://websvn.kde.org/branches/KDE/3.5/kdebase/kioslave/media/mediamanager/halbackend.h?r1=601028&r2=615516&diff_format=u


libhal crashes left and right when you pass non existing UDIs,
so we're better more careful than crashing kded
http://websvn.kde.org/branches/KDE/3.5/kdebase/kioslave/media/mediamanager/halbackend.cpp?r1=601033&r2=603818

don't handle floppy drives as with old HAL versions - newer
ones have a volume on its own, so better use that one (still
leaving older logic in place)
http://websvn.kde.org/branches/KDE/3.5/kdebase/kioslave/media/mediamanager/halbackend.h?r1=624881&r2=657182
http://websvn.kde.org/branches/KDE/3.5/kdebase/kioslave/media/mediamanager/halbackend.cpp?r1=615516&r2=657182


Init DBusError to avoid problems like:
3104: arguments to dbus_move_error() were incorrect, assertion "(dest) == NULL || !dbus_error_is_set ((dest))" failed in file dbus-errors.c line 243.
http://websvn.kde.org/branches/KDE/3.5/kdebase/kioslave/media/mediamanager/halbackend.cpp?r1=603818&r2=605183


- Fixed a small memleak: use libhal_free_string_array(volumes) instead
  of free(volumes)
- USB floppy drives have media-detection enabled. Thus we can react on
  insertion of a floppy disk
http://websvn.kde.org/branches/KDE/3.5/kdebase/kioslave/media/mediamanager/halbackend.h?r1=657182&r2=740044&diff_format=u
http://websvn.kde.org/branches/KDE/3.5/kdebase/kioslave/media/mediamanager/halbackend.cpp?r1=724100&r2=740044
Comment 6 Issue Tracker 2008-12-01 11:55:47 EST


This event sent from IssueTracker by gasmith 
 issue 220062
it_file 177514
Comment 10 ritz 2008-12-08 07:15:31 EST
we seem to be trying to mount volume. ood.
Comment 11 ritz 2008-12-08 07:16:34 EST
Created attachment 326118 [details]
lshal o/p
Comment 12 Issue Tracker 2008-12-08 14:46:28 EST
most likely, the culprit seems to be 
udi = '/org/freedesktop/Hal/devices/platform_floppy_0_storage'

from what I was able to gather from
http://bugs.kde.org/show_bug.cgi?id=120619.


Would it be possible to attach sosreport from your laptop ?





Internal Status set to 'Waiting on Support'

This event sent from IssueTracker by rkhadgar 
 issue 220062
Comment 32 Ruediger Landmann 2009-08-14 02:13:49 EDT
Release note added. If any revisions are required, please set the 
"requires_release_notes" flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

New Contents:
version 0.5 of the Hardware Abstraction Layer (HAL) creates child device objects only when a file system is mounted. In cases where a storage device cannot be polled (for example, a floppy drive or IDE Zip drive), HAL adds mount methods to the device itself rather than the volume. Previously, this meant that when used in conjunction with HAL 0.5, KDE 3 would not allow users to mount filesystems on devices which the HAL could not poll. KDE now includes a modified HAL back end that allows users to mount and unmount volumes through the storage devices detected by the HAL.
Comment 33 errata-xmlrpc 2009-09-02 05:37:34 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1277.html

Note You need to log in before you can comment on or make changes to this bug.