Bug 469755 - notify-send doesn't work
notify-send doesn't work
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: notification-daemon (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Zeuthen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-03 16:47 EST by Casey Dahlin
Modified: 2014-06-18 04:46 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-03 15:45:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Casey Dahlin 2008-11-03 16:47:48 EST
Running notify-send hello terminates normally with no errors visible anywhere, but I don't see a notification. I've noticed this on several installs across multiple machines. I'm guessing it has something to do with some piece of configuration I do personally since nobody else seems to have this issue.
Comment 1 Casey Dahlin 2008-11-03 16:50:42 EST
I just checked, and on a fresh user account with no theme changes notification works.
Comment 2 Casey Dahlin 2008-11-15 16:59:38 EST
Found the problem:

If you have a gnome terminal that you have full-screened with F11, the notifications don't show. To an extent that might seem correct, but they don't show on /any/ workspace, even if the current workspace has no full-screened windows.

Moving and modifying...
Comment 3 Colin Walters 2008-11-15 17:41:24 EST
I can't reproduce this with metacity; but my guess is that this is a bug in the interaction between libwnck and compiz, because how compiz does workspaces/desktops is "special".  Look at src/daemon/daemon.c:fullscreen_window_exists in notification-daemon.
Comment 4 Casey Dahlin 2008-11-29 23:58:35 EST
Problem is gone in F10. Should we call that the end of it?
Comment 5 Colin Walters 2008-12-03 15:45:18 EST
<stamp> THE END.

Note You need to log in before you can comment on or make changes to this bug.