Bug 469767 - 32 bit Windows guests with 4GB of RAM and PV drivers installed will not boot.
32 bit Windows guests with 4GB of RAM and PV drivers installed will not boot.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xenpv-win (Show other bugs)
5.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: Paolo Bonzini
Virtualization Bugs
:
Depends On:
Blocks: 518405
  Show dependency treegraph
 
Reported: 2008-11-03 17:09 EST by Barry Donahue
Modified: 2013-01-10 21:29 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-16 08:44:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of WinXP-sp3 32-bit with pv under xen (400.70 KB, image/png)
2009-02-26 06:24 EST, ashok
no flags Details

  None (edit)
Description Barry Donahue 2008-11-03 17:09:15 EST
Description of problem: If you have a 32 bit XP or Windows 2003 guest with 4GB of RAM, it will work fine until you install the PV drivers. When you try to reboot the system, it hangs at the Black Windows 2003 screen. The guest is getting a lot of CPU time but does not advance in the boot process.


Version-Release number of selected component (if applicable):
Dom 0 is RHEL 5.3
Guest id Windows 2003 Standard Edition.
PV drivers version is 0.97.4.

How reproducible: Every time.


Steps to Reproduce:
1.Create a 32 bit guest with 4 GB of RAM.
2.Install PV drivers and reboot

  
Actual results: The system will hang on boot.


Expected results: It should boot


Additional info:
Comment 1 Bill Burns 2008-11-14 13:01:56 EST
Barry email comment on this from Scott at OSR from Sep 16:

From: Scott Noone 
Sent: Tuesday, September 16, 2008 12:03 PM
To: osr-devel@redhat.com
Cc: dmkbugs
Subject: RE: FogBugz (Case 12192) RHEL 5 PV Drivers - 4096MB Memory Limitation with PV Drivers Installed (32-bit guests)

Can you retry this with the latest and greatest code? We finally got the test system configured with enough RAM and assigned a 32bit Server 2003 domU 4096MB of RAM and it booted fine. This was on an x64 dom0 running whatever version of 5.2 you guys sent over recently.

Not sure what would have changed to fix this, but it would be a start.

-scott

Barry, I think you recently confirmed that this issue still exists on the latest drivers. What version were the drivers? Can we get explicit config and environment info (host specifics too) for the 32 bit guest you test? Perhaps that will help them reproduce this. If they cannot then it's time to get the debug setup done here.

Thanks,
 Bill
Comment 2 Bill Burns 2008-11-14 13:03:50 EST
Ahh nevermind...I see this is a new bug and the info is in comment #1.
Comment 3 Barry Donahue 2008-11-14 13:38:05 EST
I did retry this again with version 97.4 and hit the problem.
Comment 4 ashok 2009-02-25 01:33:23 EST
I don't have access to machines with 4GB ram here locally I am trying to persue local manager to arrange one for me.
Comment 5 ashok 2009-02-26 06:24:43 EST
Created attachment 333313 [details]
screenshot of WinXP-sp3 32-bit with pv under xen
Comment 6 ashok 2009-02-26 06:32:50 EST
Please see the attachment png file. I have installed the PV driver on Guest.
The Image shows Xen VM has assigned 6GB of ram, the Guest detects 4GB, it is normal. 

details:

guest : WinXP-sp3
Host : 2.6.18-128.1.1.el5xen #1 SMP x86_64 GNU/Linux
PVdriver : 1.0.0.1
Comment 8 David Deaderick 2009-07-16 16:23:55 EDT
Notice that the Memory in Windows is less than 4GB, this is because you have not set the /PAE switch in c:\boot.ini
Comment 9 Paolo Bonzini 2009-08-20 07:55:24 EDT
Assigning to myself for triaging.
Comment 10 Paolo Bonzini 2009-09-02 11:36:31 EDT
It works with the latest drivers, either with or without PAE (though it reports 3.8 GB even if I enable PAE).

I shall test in the next few days with the RHEL 5.4 released drivers.
Comment 11 Paolo Bonzini 2009-09-15 12:14:04 EDT
Anyway, MODIFIED now that 1.0.90-2 has been built.
Comment 16 koka xiong 2009-10-29 23:59:26 EDT
1.Having installed windows 32 guest with RAM>4G and installed windows XP  SP3 32 bit guest with RAM>4G
2.Install the xenpv-win driver
3.After install the xenpv-win driver, restart the system
After the system is restarted,it can boot well.
Comment 21 errata-xmlrpc 2009-11-16 08:44:55 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1583.html

Note You need to log in before you can comment on or make changes to this bug.