This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 469777 - Hardcoded /usr/lib plugin path for 64-bit multiarch platforms
Hardcoded /usr/lib plugin path for 64-bit multiarch platforms
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: vamp-plugin-sdk (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Michel Alexandre Salim
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-03 19:56 EST by Michael Schwendt
Modified: 2009-03-02 09:02 EST (History)
2 users (show)

See Also:
Fixed In Version: 1.3-3.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-24 15:53:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Schwendt 2008-11-03 19:56:20 EST
The Vamp plugin path, which is hardcoded in the library, is wrong
for 64-bit multi-arch platforms:

  $ strings libvamp-hostsdk.so.2.1.0 |grep usr
  $HOME/vamp:$HOME/.vamp:/usr/local/lib/vamp:/usr/lib/vamp

The file to patch is: ./vamp-sdk/PluginHostAdapter.cpp
Ought to become:
  $HOME/vamp:$HOME/.vamp:/usr/local/lib64/vamp:/usr/lib64/vamp

Fedora 9 and older are also affected. We'll use this library for
Audacity, which so far was built with an included/patched copy
of the Vamp API.
Comment 1 Bug Zapper 2008-11-25 23:43:24 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Fedora Update System 2008-12-30 02:02:26 EST
vamp-plugin-sdk-1.3-2.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/vamp-plugin-sdk-1.3-2.fc10
Comment 3 Fedora Update System 2008-12-30 02:02:28 EST
vamp-plugin-sdk-1.3-2.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/vamp-plugin-sdk-1.3-2.fc9
Comment 4 Fedora Update System 2008-12-30 18:41:24 EST
vamp-plugin-sdk-1.3-2.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update vamp-plugin-sdk'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2008-11832
Comment 5 Fedora Update System 2008-12-30 18:50:34 EST
vamp-plugin-sdk-1.3-2.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing-newkey update vamp-plugin-sdk'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-11914
Comment 6 Michael Schwendt 2009-01-03 08:24:25 EST
vamp-sdk/hostext/PluginLoader.cpp  PluginLoader::Impl::generateTaxonomy()  contains a hardcoded "/lib/"
Comment 7 Fedora Update System 2009-01-16 18:46:04 EST
vamp-plugin-sdk-1.3-2.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2009-01-16 18:47:30 EST
vamp-plugin-sdk-1.3-2.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Michael Schwendt 2009-01-17 05:14:30 EST
Re: comment 6

src/vamp-hostsdk/PluginLoader.cpp:    string libfragment = "/lib/";
Comment 10 Michael Schwendt 2009-01-17 15:22:09 EST
The Fedora 9 update is ABI/API incompatible. :(

Originally, this ticket was about Rawhide. Then the bug-zappers modified it to target F10. Then an incompatible upgrade for F9 has been released. Not funny.
Comment 11 Fedora Update System 2009-02-24 15:53:01 EST
vamp-plugin-sdk-1.3-3.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2009-02-24 16:02:47 EST
vamp-plugin-sdk-1.3-3.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Kevin Kofler 2009-02-25 01:39:29 EST
You said right there in the report that "Fedora 9 and older are also affected." so I don't understand your surprise at an update fixing it in F9 having been pushed.
Comment 14 Michael Schwendt 2009-02-25 02:14:20 EST
Kevin,

an ABI/API-incompatible upgrade has been pushed to stable instead of a simple fix/patch for this bug. I don't mind multiple updates and multiple notifications from bodhi, but it cannot be that all of the testing of new major versions is put onto my shoulders just because I reported a Fedora-specific customisation-bug which required a patch. Communication in this ticket is non-existant. Comment 6 should not have been ignored. 

My surprise is that the F-9 upgrade has been pushed to stable without testing => breaking deps for multiple packages.
Comment 15 Michel Alexandre Salim 2009-03-02 09:02:01 EST
Indeed, I made a mistake in
1) not catching the second /lib reference
2) pushing the build to F-9

Both packages *have* been put into testing, though (see the Bodhi logs). I apologize for forgetting to do repoquery, but the feedback on the F-9 build only came *after* this enters stable.

1.3-3 is pushed direct to stable since 1.3-2 has landed anyway. Again, apologies for this problem.

Note You need to log in before you can comment on or make changes to this bug.