Bug 469818 - intel driver 3d acceleration very slow with 945GM
intel driver 3d acceleration very slow with 945GM
Status: CLOSED DUPLICATE of bug 444328
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-04 04:17 EST by Pancrazio `ezio' de Mauro
Modified: 2009-10-22 09:01 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-06 03:57:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
X logs (170.35 KB, text/plain)
2008-11-04 04:17 EST, Pancrazio `ezio' de Mauro
no flags Details
Lenovo Thinkpad X60s Hardware information (28.11 KB, text/plain)
2008-11-04 04:23 EST, Pancrazio `ezio' de Mauro
no flags Details

  None (edit)
Description Pancrazio `ezio' de Mauro 2008-11-04 04:17:44 EST
Created attachment 322400 [details]
X logs

Description of problem:

3d acceleration (glxgears, compiz, composition, etc.) is very slow on my Lenovo Thinkpad X60s

Version-Release number of selected component (if applicable):

xorg-x11-drv-i810-2.5.0-1.fc10.i386

How reproducible:

Enable desktop effects. Scrolling in applications like firefox becomes very slow, exposé becomes slow, windows visibly fade in and out (i.e. slower than intended).

Regardless of desktop effects active or not, glxgears shows around 330 FPS, about half of what the same hardware produces with Fedora 8.

Potentially interesting messages from Xorg.0.log:

(WW) Falling back to old probe method for fbdev
(WW) Falling back to old probe method for vesa
(WW) intel(0): libpciaccess reported 0 rom size, guessing 64kB
(WW) intel(0): Unknown vendor-specific block f
(WW) intel(0): Register 0x61200 (PP_STATUS) changed from 0xc0000008 to 0xd000000a
(WW) intel(0): PP_STATUS before: on, ready, sequencing idle
(WW) intel(0): PP_STATUS after: on, ready, sequencing on
(WW) intel(0): Register 0x71024 (PIPEBSTAT) changed from 0x00020202 to 0x00020000
(WW) intel(0): PIPEBSTAT before: status: VBLANK_INT_ENABLE VSYNC_INT_STATUS VBLANK_INT_STATUS
(WW) intel(0): PIPEBSTAT after: status: VBLANK_INT_ENABLE
(EE) intel(0): Failed to set tiling on front buffer: rejected by kernel
(EE) intel(0): Failed to set tiling on back buffer: rejected by kernel
(EE) intel(0): Failed to set tiling on depth buffer: rejected by kernel
(WW) intel(0): ESR is 0x00000001, instruction error
(WW) intel(0): PRB0_CTL (0x0001f001) indicates ring buffer enabled
(WW) intel(0): Existing errors found in hardware state.
(WW) intel(0):   Hardware claims pipe A is on while software believes it is off

/proc/mtrr shows:

reg00: base=0x00000000 (   0MB), size=2048MB: write-back, count=1
reg01: base=0x7f700000 (2039MB), size=   1MB: uncachable, count=1
reg02: base=0x7f800000 (2040MB), size=   8MB: uncachable, count=1
reg03: base=0xd0000000 (3328MB), size= 256MB: write-combining, count=1

Attaching full Xorg.0.log, lspci and dmidecode in hardware-info.txt

X starts without configuration file
Comment 1 Pancrazio `ezio' de Mauro 2008-11-04 04:23:14 EST
Created attachment 322401 [details]
Lenovo Thinkpad X60s Hardware information
Comment 2 Eric Hansin 2008-11-06 20:35:48 EST
I have the same issue, at least with Compiz and everything being very slow.  I have the Intel 945Gx chipset.  It is very pronounced when I move a window or resize a window.

Also, if it helps, I am running on a Dell Latitude D520 laptop.  This was not an issue on F9.

Please let me know if there are any details or specific information I can add.
Comment 3 Bojan Smojver 2008-11-22 20:12:08 EST
Ditto Dell Inspiron 6400 with Intel GMA 945. Painfully slow...
Comment 4 Bug Zapper 2008-11-25 23:43:41 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Matěj Cepl 2008-12-04 17:48:16 EST

*** This bug has been marked as a duplicate of bug 444328 ***
Comment 6 Vedran Miletić 2009-09-06 03:57:09 EDT

*** This bug has been marked as a duplicate of bug 444328 ***

Note You need to log in before you can comment on or make changes to this bug.