Bug 469835 - NM doesn't identify wireless devices on the XO
NM doesn't identify wireless devices on the XO
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks: FedoraOnXO
  Show dependency treegraph
 
Reported: 2008-11-04 05:53 EST by Alexander Todorov
Modified: 2008-11-04 13:23 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-04 13:23:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
NM on the XO (74.77 KB, image/png)
2008-11-04 05:53 EST, Alexander Todorov
no flags Details

  None (edit)
Description Alexander Todorov 2008-11-04 05:53:56 EST
Created attachment 322407 [details]
NM on the XO

Description of problem:
In NM both mesh and standard wireless devices are showing as "Marvell MARVELL Wireless Device". This leads to confusion when you need to select which device to use (i.e. when connecting to a hidden network)

Version-Release number of selected component (if applicable):
NetworkManager-0.7.0-0.11.svn4201.fc10.i386

How reproducible:
Always

Steps to Reproduce:
1. Click the NM applet icon while running on the XO laptop
  
Actual results:
See screenshot

Expected results:
Both wireless devices (mesh and regular) are identified in a distinguishable manner.

Additional info:
Comment 1 Dan Williams 2008-11-04 13:23:47 EST
This is because they actually _are_ indistinguishable.  The OLPC wireless stuff is "special" and the interfaces do not conform to the standard method of specifying wifi interfaces in Linux.  Thus, it's not supported at this time.

The OLPC guys are working on proper support.

Note You need to log in before you can comment on or make changes to this bug.