This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 469850 - semanage does not have the rights to fix reloc failure in libjvm.so
semanage does not have the rights to fix reloc failure in libjvm.so
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
rawhide
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-04 08:22 EST by ghherlin
Modified: 2008-11-04 08:55 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-04 08:55:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
initial selinux report with suggestions that fail (3.23 KB, text/plain)
2008-11-04 08:22 EST, ghherlin
no flags Details

  None (edit)
Description ghherlin 2008-11-04 08:22:10 EST
Created attachment 322420 [details]
initial selinux report with suggestions that fail

Description of problem:

semanage does not have the se-policy rights to change the roghts to permitcorrect execution of libjvm.so
(semanage fcontext -a -t textrel_shlib_t '/opt/jdk1.6.0_10/jre/lib/i386/server/libjvm.so')



Version-Release number of selected component (if applicable): FC10Snap3


How reproducible:




Steps to Reproduce:
Install Sun's  1.6.0_10 JDKas describen in http://fedorasolved.org/browser-solutions/java-i386
Start Opera.
selinux comes up with the relocation failure message attached.
Attempt the suggested authorization mantras.
  
Actual results:
see attached selinux troubleshooting output files.files


Expected results:
success of the (last) semanage step.


Additional info:
Comment 1 Daniel Walsh 2008-11-04 08:55:34 EST
Just run restorecon on the library it should be labeled correctly the problem is you installed it from a non rpm so it did not label the file correctly

restorecon -R -v /opt

Note You need to log in before you can comment on or make changes to this bug.