Bug 469872 - [RFE] Support for sun4us Systems
[RFE] Support for sun4us Systems
Status: CLOSED WONTFIX
Product: Spacewalk
Classification: Community
Component: Server (Show other bugs)
0.2
sparc64 Other
medium Severity medium
: ---
: ---
Assigned To: Todd Sanders
Red Hat Satellite QA List
: FutureFeature
Depends On:
Blocks: spacewalk-rfe
  Show dependency treegraph
 
Reported: 2008-11-04 10:50 EST by support
Modified: 2015-03-30 11:59 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-03-30 11:59:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description support 2008-11-04 10:50:02 EST
Description of problem:

When trying to register a sun4us System the following Messages appears:

Error Message:
    Architecture `sparc-sun4us-solaris' is not supported
Error Class Code: 24
Error Class Info: Unsupported server architecture.
Explanation: 
     An error has occurred while processing your request. If this problem
     persists please enter a bug report at bugzilla.redhat.com.
     If you choose to submit the bug report, please be sure to include
     details of what you were trying to do when this error occurred and
     details on how to reproduce this problem.


Version-Release number of selected component (if applicable):


How reproducible:

execute rhnreg_ks on sun4us system

Steps to Reproduce:
1.
2.
3.
  
Actual results:



Expected results:

System should be registered on Spacewalk Server

Additional info:

prtdiag output:

System Configuration:  Sun Microsystems  sun4us Fujitsu Siemens PRIMEPOWER450 2x SPARC64 V
System clock frequency: 220 MHz
Memory size: 8192 Megabytes
Comment 1 Clifford Perry 2009-07-27 15:53:14 EDT
Sadly I am not aware of any access to this hardware. I do not feel comfortable approving this, not unless I had a sane method to strip out this when we took the code changes into Satellite, since Spacewalk is upstream for Satellite. 

Cliff
Comment 2 support 2010-05-05 11:02:12 EDT
I have a sun4us box at home and could arrange access via VPN to it, if this helps to port the client. If one of you is interested, please contact me directly via my private e-mail address: michael -at- moll -dot- name
Comment 3 Jan Pazdziora 2010-11-19 11:03:52 EST
Mass-moving to space13.
Comment 4 Miroslav Suchý 2011-04-11 03:32:27 EDT
We did not have time for this one during Spacewalk 1.4 time frame. Mass moving to Spacewalk 1.5.
Comment 5 Miroslav Suchý 2011-04-11 03:36:47 EDT
We did not have time for this one during Spacewalk 1.4 time frame. Mass moving to Spacewalk 1.5.
Comment 6 Jan Pazdziora 2011-07-20 07:50:22 EDT
Aligning under space16.
Comment 94 Grant Gainey 2015-03-30 11:59:43 EDT
As of the 2.3 release, Spacewalk no longer supports Solaris. Closing.

Note You need to log in before you can comment on or make changes to this bug.