This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 469873 - Fix anaconda build break with libaudit
Fix anaconda build break with libaudit
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
5.3
All Linux
urgent Severity urgent
: rc
: ---
Assigned To: Hans de Goede
Alexander Todorov
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-04 10:58 EST by Denise Dumas
Modified: 2009-01-20 16:32 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 16:32:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Denise Dumas 2008-11-04 10:58:15 EST
Description of problem:

libaudit.h change causes anaconda build to break, because anaconda has private "mini-daemon". The fix is to use struct audit_reply instead of struct auditd_reply_list


Per SteveG: 
libaudit.h defines the structure which is available to the public, but nothing in libaudit actually uses it. The only things are internal, so it was 
removed. From 1.6.5:

[sgrubb@centaur audit-1.6.5]$ grep -rl auditd_reply_list *
lib/libaudit.h
src/auditd-config.h
src/auditd-event.c
src/auditd-event.h
src/auditd-reconfig.c
src/auditd.c

In 1.7.7, its now defined internally to auditd-event.h because we needed to 
expand its size and it appears to never have been intended for public use. 
Meaning, nothing in libaudit takes it as an argument or returns its type, so 
the anaconda people can just define the struct if they want and keep using 
it.
Comment 3 Hans de Goede 2008-11-05 07:44:31 EST
This is fixed with this commit:
http://git.fedorahosted.org/git/?p=anaconda.git;a=commitdiff;h=04c33a7179b48115afa1a0c01d2a83bdc4b7cfef

Which is in anaconda-11.1.2.153-1, which has just been build.
Comment 6 Alexander Todorov 2008-11-10 08:48:27 EST
anaconda-11.1.2.154-1 built successfully with audit-libs-1.7.7-5.el5
Comment 8 errata-xmlrpc 2009-01-20 16:32:39 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0164.html

Note You need to log in before you can comment on or make changes to this bug.