Bug 469939 - Can not send files over Bluetooth using nautilus-sendto
Can not send files over Bluetooth using nautilus-sendto
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: nautilus-sendto (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-04 15:18 EST by Hedayat Vatankhah
Modified: 2009-03-25 12:03 EDT (History)
6 users (show)

See Also:
Fixed In Version: 1.1.2-1.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-25 12:03:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hedayat Vatankhah 2008-11-04 15:18:23 EST
Description of problem:
When I want to send a file over bluetooth using nautilus-sendto, it prints an error message at the bottom of the sendto window:

Programming err...device in the list

and it doesn't send the file. But I can send files by right clicking on the bluetooth icon and selecting "Send files to device..."

Version-Release number of selected component (if applicable):
1.1.0-1.fc10

How reproducible:
Always

Steps to Reproduce:
1.Right click on a file
2. Select Send To...
3. Select Send as Bluetooth
4. Select a device in Send to combo box
5. Press Send
  
Actual results:
Prints an error message at the bottom of the Send to window:
Programming err...device in the list

Expected results:
Should start sending the file to the selected device
Comment 1 George Billios 2008-11-16 06:45:51 EST
I confirm this with same nautilus-sendto version.

Deleted schemes from gconf, reinstalled, tried to find where it stores previous entries for bluetooth devices with no luck....
Comment 2 Bug Zapper 2008-11-25 23:46:36 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Patrick Steiner 2008-12-12 05:05:18 EST
I have updated my bluez stuff to 4.22 relase 2.fc10

from:

http://koji.fedoraproject.org/koji/buildinfo?buildID=74002

Now sending and browsing bluetooth devices work again.

nautilus-sendto functions doesnt work yet.
i have to send files via the bluetooth-applet.
Comment 4 Edmond Hui 2008-12-13 22:10:57 EST
v4.19 currently on repository just doesn't work at all, period.

Tried this new v4.22, it rocks. Gnome bluetooth applet setting works again, pairing works, file transfer via bluetooth applet (both send and receive) works. 

This version should push out ASAP.

Thanks for the fix!
Comment 5 Patrick Steiner 2008-12-14 04:28:44 EST
If i try to send a file via nautilus-sendto i get the error :

Obex Push file transfer unsupported

Sending files directly via the bluetooth-applet works fine.
Comment 6 Hedayat Vatankhah 2009-01-12 07:27:14 EST
It seems that it works if the device have been previously set up using the bluetooth applet.
Comment 7 Patrick Steiner 2009-01-12 07:43:18 EST
I can confirm this!
Comment 8 Michael Cronenworth 2009-01-24 15:44:17 EST
This bug was fixed in the bluez updates. You have to setup bluetooth devices with the new wizard now otherwise OBEX transfers from nautilus will fail. Even if you previously setup your device, you need to delete it and add it with the wizard.

I wish this was *DOCUMENTED* in the update. The bluez folks hate documentation it seems.
Comment 9 Fedora Update System 2009-03-05 10:56:25 EST
nautilus-sendto-1.1.2-1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/nautilus-sendto-1.1.2-1.fc10
Comment 10 Fedora Update System 2009-03-09 18:54:21 EDT
nautilus-sendto-1.1.2-1.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update nautilus-sendto'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-2484
Comment 11 Fedora Update System 2009-03-25 12:03:38 EDT
nautilus-sendto-1.1.2-1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.