Bug 469947 - file conflicts: file /usr/bin/spawn-fcgi conflicts between attempted installs of cherokee-0.8.1-2.fc10.ppc and lighttpd-fastcgi-1.4.20-1.fc10.ppc
file conflicts: file /usr/bin/spawn-fcgi conflicts between attempted installs...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: cherokee (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Pavel Lisý
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F10Blocker/F10FinalBlocker
  Show dependency treegraph
 
Reported: 2008-11-04 15:56 EST by James Laska
Modified: 2013-09-02 02:29 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-06 14:21:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
/tmp/anaconda.log (25.12 KB, text/plain)
2008-11-04 15:56 EST, James Laska
no flags Details

  None (edit)
Description James Laska 2008-11-04 15:56:16 EST
Created attachment 322483 [details]
/tmp/anaconda.log

Installing all packages from rawhide/ppc results in file conflicts:

19:00:22 ERROR   : file conflicts: file /usr/bin/spawn-fcgi conflicts between attempted installs of cherokee-0.8.1-2.fc10.ppc and lighttpd-fastcgi-1.4.20-1.fc10.ppc
19:00:22 ERROR   : file conflicts: file /usr/share/man/man1/spawn-fcgi.1.gz conflicts between attempted installs of cherokee-0.8.1-2.fc10.ppc and lighttpd-fastcgi-1.4.20-1.fc10.ppc
Comment 1 James Laska 2008-11-04 15:57:55 EST
Conflicts exist on an i386 install as well.

09:55:00 ERROR   : file conflicts: file /usr/bin/spawn-fcgi conflicts between attempted installs of cherokee-0.8.1-2.fc10.i386 and lighttpd-fastcgi-1.4.20-1.fc10.i386
09:55:01 ERROR   : file conflicts: file /usr/share/man/man1/spawn-fcgi.1.gz conflicts between attempted installs of cherokee-0.8.1-2.fc10.i386 and lighttpd-fastcgi-1.4.20-1.fc10.i386
Comment 2 Tom Horsley 2008-11-04 22:26:52 EST
Yep. I just got this same conflict installing the fedora 10 preview i386
from the DVD image.
Comment 3 Till Maas 2008-11-06 10:18:54 EST
They should be both the same program, accoding to cherokee svn, they copied it from lighttpd:

http://svn.cherokee-project.com/browser/cherokee/trunk/contrib/spawn-fcgi.c
Comment 4 John Poelstra 2008-11-06 12:12:19 EST
changed platform to "i386" to make it known that this bug is not isolated to PPC also adding to blocker based on conflict installing from media.
Comment 5 James Laska 2008-11-06 12:15:44 EST
Only one package can own a file on disk.  You might consider consulting fedora-packaging (http://www.redhat.com/mailman/listinfo/fedora-packaging) for guidance on properly resolving this issue.
Comment 6 Tom "spot" Callaway 2008-11-06 13:56:12 EST
The sanest fix here seems to be for the cherokee package to Require: lighttpd-fastcgi. This isn't perfect, because it means that cherokee will pull in libghttpd as a dependency, but it avoids the conflict (and lighttpd is small).

I've committed the change to cherokee and kicked off a build:

http://koji.fedoraproject.org/koji/taskinfo?taskID=919651

I'll request F10 tagging when it is done.
Comment 7 Jesse Keating 2008-11-06 14:21:36 EST
It has been tagged.

Note You need to log in before you can comment on or make changes to this bug.