Bug 469971 - Upgrade between major releases fails due cert version mismatch
Upgrade between major releases fails due cert version mismatch
Status: CLOSED NOTABUG
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Upgrades (Show other bugs)
520
All Linux
medium Severity medium
: ---
: ---
Assigned To: Clifford Perry
Brandon Perkins
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-04 17:39 EST by Thorsten Scherf
Modified: 2008-11-06 11:28 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-06 10:44:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thorsten Scherf 2008-11-04 17:39:41 EST
Description of problem:
upgrade from rhns-4.2 to 5.2 fails because install.pl tries to activate the server, this doesn't work because of cert version mismatch. calling rhn-satellite-activate manually afterwards also fails, you have to upgrade the schema to 5.2 first. after this change has been done, activation finally worked. we definitely should add an option for the cert version mismatch problem to the install.pl script, otherwise script will never run successfully when you upgrade between different major-releases.

upgrade docs should be changed as well.

Version-Release number of selected component (if applicable):
rhns-5.2

How reproducible:
install.pl --disconnected 

Steps to Reproduce:
1.
2.
3.
  
Actual results:
install.pl fails

Expected results:
install.pl runs successfully

Additional info:
Comment 2 Thorsten Scherf 2008-11-06 11:28:52 EST
any comments on this?

Note You need to log in before you can comment on or make changes to this bug.