Bug 470030 - IPv6 support in NFS
IPv6 support in NFS
Status: CLOSED DUPLICATE of bug 463530
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All All
high Severity high
: ---
: ---
Assigned To: Jeff Layton
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-05 06:48 EST by Jeff Layton
Modified: 2009-05-04 07:48 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-04 07:48:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Layton 2008-11-05 06:48:45 EST
+++ This bug was initially created as a clone of Bug #463530 +++

=Comment: #1=================================================
Emily J. Ratliff <emilyr@us.ibm.com> - 2008-09-17 11:13 EDT
1. Feature Overview:
Feature Id:	[201026]
a. Name of Feature:	IPv6 support in NFS - kernel
b. Feature Description
To add the support of IPv6 in NFS.  Several components: 1) The client side IPv6
support should be completed in 2.6.21. 2) The server side IPv6 support is in
progress. 3) The NFS commands/tools/utils packages is already available since 1.0.10

2. Feature Details:
Sponsor:	LTC
Architectures:
x86
x86_64
ppc64
s390 native
s390 compat
s390x

Arch Specificity: Purely Common Code
Delivery Mechanism: 
Category:	Remote Filesystems
Request Type:	Kernel - Enhancement from IBM
d. Upstream Acceptance:	In Progress
Sponsor Priority	1
f. Severity: High
IBM Confidential:	no
Code Contribution:	3rd party code
g. Component Version Target:	server support in progress, other parts are
upstream:  2.6.21 -> client support  nfs-utils 1.0.10 -> userspace tools (in a
separate request)

3. Business Case
IPv6 support in NFS is needed for several customers and is required for some
government contracts (all DoD contracts).

Benefits
NFS over IPv6 would provide more flexibility to customers to configure their
networks to meet their needs.

4. Primary contact at Red Hat: 
John Jarvis
jjarvis@redhat.com

5. Primary contacts at Partner:
Project Management Contact:
Sarah Wright, sarahw@us.ibm.com, 503-578-5145

Technical contact(s):
Frank Filz, ffilz@us.ibm.com
Varun Chandramohan, varuncha@in.ibm.com

IBM Manager:
Jeffrey Heroux, heroux@us.ibm.com

--- Additional comment from notting@redhat.com on 2008-10-02 15:23:55 EDT ---

We should have the client and utilities handled fine in RHEL 6. What's the status of the server support?

--- Additional comment from bugproxy@us.ibm.com on 2008-10-02 23:16:53 EDT ---

The server support is still not ready as of 2.6.27-rc6. I have been able to get a successful mount over ipv6 but with lots of undesired hacks. The main kernel patches i used are http://nfsv4.bullopensource.org/patches/ipv6-server/2.6.27-rc3/patch1_rpcbindv4 and http://nfsv4.bullopensource.org/patches/ipv6-server/2.6.27-rc3/patch2_ipv6overrpcbindv4. They both seems to work fine. But they are not upstream yet.
Comment 1 Jeff Layton 2008-11-05 07:00:03 EST
I'm starting on this by just looking at where we are upstream.

I've built a kernel from Chuck Lever's git tree (tag cel-ipv6-10292008). It looks like the v6 nfsd and lockd ports are being registered with rpcbind by the kernel. The big stumbling block at this point is userspace support. When I build nfs-utils 1.1.4 with --enable-ipv6, rpc.mountd fails to start:

# rpc.mountd -F
mountd: unable to register (mountd, 1, udp)

...so there is still some work to be done there.

On the client side, the userspace mount helper looks like it does the right thing, at least for nfsv4:

    mount("localhost6:/", "/mnt/test", "nfs4", 0, "clientaddr=::1,addr=::1"...

...but I need a working server in order to test out the client side fully.
Comment 2 Jeff Layton 2008-11-17 16:01:57 EST
Opensolaris apparently has a working IPv6 server, so I set that up as a KVM guest. I took another rawhide kvm guest and built a nfs-utils package with --enable-ipv6. With that, I'm able to mount nfsv4 mounts via IPv6, and nfsv3 mounts if I use -o nolock.

Presumably, the nfsv3 code doesn't work because statd isn't yet ipv6 enabled.

I think the client kernel piece is basically working. Obviously we'll need to run some better testing, esp once we have a working statd. It looked like Chuck sent some nfs-utils patches last week for statd and ipv6. I'll see about pulling those down soon and checking them out.
Comment 3 Bug Zapper 2008-11-25 23:48:59 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Jeff Layton 2009-05-04 07:48:58 EDT

*** This bug has been marked as a duplicate of bug 463530 ***

Note You need to log in before you can comment on or make changes to this bug.